Need For Kill - v 0.70

HOTSEAT

Hotseat Mode. (2 people at the same computer).
The "HotSeat" window consist of:
At the top-left - list of the maps. U can change maps, using up & down cursor keys. At the right you can see game settings and player properties. There u can edit properties of both players. 1st player plays on the mouse, second on the keyboard. (u can redefine it). There is 4 parameters for Game Settings: "warmup, fraglimit,timelimit, gametype". Warmup - time before match starts. Fraglimit - Frag limitter. Timelimit - Time limitter. Gametype - a type of the game (DeathMatch, RailArena and Practice). Recomended settings for 1v1 is: warmup 180; fraglimit 0; timelimit 10. To begin the play press "Fight". When map loaded and the countdown began you can type console command "ready" (or press F10) to begin the match without warmup.

BOTS

NFK supports bots. nfk supplied with Gyper*bot. To start playing with bot - execute gyperbot/gyperbot.bat, and then, select HOTSEAT game. Choose map. Now, toggle console (by pressing ~ key) and type "addbot" command, without quotes.
Standart bot commands is: addbot, removebot
You can also plug in another bots, which you can download from www.3dpower.org

MULTIPLAYER

Support up to 8 players.
Network play available over internet or over LAN. To play over inet use NFK PLANET.
Host game:
Select the map first. And then cofigure server settings:
Hostname
Allow Join Match - Cliets can connect at any time (if enabled). Cliets can connect only at the warmup time (if disabled)
Dedicated - Yes=server without server's players.
Synchronization - Synchronization level between server and cliets. Set this to "Heavy" if fast connection speed available (LAN), or set to "Medium" or "Light" for ISDN connections.

Join game:
Select the server in the server list and press FIGHT button.

Spectator mode:
To enable this mode type "spectator 1" at the console, before connect to server. Command "nextplayer" changes current player. Dedicated server is always in the spectator mode.

Chat:
To send the chat use ENTER key. or bind it to another key (bind enter messagemode).
OR chat directly from console - type the message text and press CTRL+ENTER.

Colour names:
NFK supports colour names. The method to paint your name is the same as in quake3. You must write a colour tag before letters. Supported colors: 1234567. Put the "^" symbol before number. Example:
^1pla^3y^1er - player.
There is one more tag "^b", it makes text blinking, tag "^n" stops blinking.
//note: max name characters is 30.

Voting:
You can toggle voting for some console command, and if number of positive (YES) votes will be enough to apply this command, it will be executed at server.
You can vote for: restart, ready, map, fraglimit, timelimit, capturelimit, domlimit, warmup,warmuparmor, forcerespawn, sync, sv_teamdamage, net_predict, sv_maxplayers.
Example: "callvote restart", "callvote map tourney4". For additional infromation, read voting console commands, at CONSOLE section.

Available gametypes: DeathMatch, Teamplay, Rail Arena, Practice, Capture The Flag, Domination

GAMETYPES

 Need For Kill supports 7 game types: DeathMatch, Practice, Rail Arena, Team Play, Capture The Flag, Domination, Trick Arena.

DeathMatch
Free for all, 1 vs 1 or more ...
* Limits: fraglimit, timelimit
* Active at: Hotseat, Multiplayer

Practice
Same as DeathMatch, except players respawn with all weapons, 200 health, and 200 armor.
* Limits: fraglimit, timelimit
* Active at: Hotseat, Multiplayer

Rail Arena
Only RailGun Available. All items are removed. Players respaws already with RailGun.
* Limits: fraglimit, timelimit
* Active at: Hotseat, Multiplayer

Team Play
is a team Game, players can play in two teams (Blue and red). For killing your team-mate, your team looses one frag. Your team score then equials sum of team-mates frags.
* Limits: fraglimit, timelimit
* Active at: Multiplayer
* sv_teamdamage (hurting your team-mates): 1 (yep).
* Special panel, called TEAMBAR, is available in this type of game, it displays the status of you and your team-mates. To configure your TEAM-BAR, please check Commands Console, these commands start from "ch_teambar....".

Capture The Flag
is a team Game,the aim of the game is : to steal the enemy's flag, and bring it to your base (you flag must be at your base to score). For flag capture, your team earns capture point. The team who has more capture points, wins !!!
* Limits: capturelimit, timelimit
* Active at: Multiplayer
* CTF Bonuses: Flag capture - 5 frags. Flag recovery - 1 frag.
* sv_teamdamage (hurting your team-mates): 0 (nope).
* Special panel, called TEAMBAR, is available in this type of game.

Domination
is a team Game, While you have a control of a domination point, your team gains points. The first team who reach "dominationlimit" points wins the match.
* Limits: domlimit, timelimit
* Active at: Multiplayer
* sv_teamdamage (hurting your team-mates): 0 (nope).
* Special panel, called TEAMBAR, is available in this type of game.
* Special panel, called DOMBAR, in this type of game (it displays domination status). To configure your DOMBAR, please check Commands Console, these commands starts from "ch_dom....".

Trix Arena
Single Player game mode. like Trix Arena'playing game, you must pass through the trick map as fast as You can.
The records table for trix maps is located at www.3dpower.org.

Notes for mapmakers:
* CAPTURETHEFLAG: In this game mode, players respawns at REDRESPAWN, and BLUERESPAWN points instead of RESPAWN point. In other gametypes, "redrespawn" and "bluerespawn" are not used.
* DOMINATION: NFK will not start domination map, which contains DOMPOINTS <> 3.

MODELZ

 It is possible to play different models in NFK. NFK models - player's look. Installation to models: all models is kept in game catalogue, in basenfk\models\ directory. For example, You download the Klesk model. Copy the "klesk" directory from archive klesk.zip to basenfk\models\ directory in the NFK catalogue. Model will become available in list of the models after this. Also you can download additional models from http://powersite.narod.ru. You can choose the model through the player properties window or You can use console command "model klesk+blue","p2model klesk+red". Theoretically you may create your own models. It's painting by yourself and with NMDL program. You can find NMDL program at www.3dpower.org

DEMOZ

 It is possible to record/replay demos. To begin record You must start the game and write the console command "record mydemo1" or "autorecord". When match ends demo's recording stops itself, but if you want to stop record before the end of the match, You can use "stoprecord" console command. It is possible to replay demos from the main menu, in section DEMOS or by console command "demo mydemo1". There is command "speeddemo" for accelerate\decelerate demo's replay speed. Read the "CONSOLE" section for more detailes. Speed control also available at num+, num- numpad keys

BINDINGZ

 You can rebind general controls through "player properties" + "customize controls" screen.

NOTE: It's impossible to bind series of the commands (for example "bind space fire; nextweapon; kill".
It is possible to bind mouse, and completely rebind mouse controls on keyboard (versions nfkbeta 0.30 and more). You can write Your configs to fast NFK setup...

It is all binding commands:
bind {key} {action}

The {key} parameter may be:
A,B,C,D....Z
1,2,3..0
shift, ctrl, alt, tab, space, capslock, num0, num1, num2, num3, num4, num5, num6, num7, num8, num9, num0, num/, num*, num-, num+, num., enter, insert, home, pgup, pgdown, delete, end, backspace, leftarrow, rightarrow, uparrow, downarrow,
mbutton1,mbutton2,mbutton3 - mouse buttons.

The {action} parameter may be:
moveleft, moveright, moveup, movedown, nextweapon, prevweapon, lookup, lookdown, fire, center, weapon0, weapon1, weapon2, weapon3, weapon4, weapon5, weapon6, weapon7, weapon8, p2moveleft, p2moveright, p2moveup, p2fire, p2nextweapon, p2prevweapon, p2lookup, p2lookdown, p2center, p2weapon0, p2weapon1, p2weapon2, p2weapon3, p2weapon4, p2weapon5, p2weapon6, p2weapon7, p2weapon8, scoreboard.

Example:
the "p2" attachment means, that this command for the second player. Below is attached example of full bindlist for player 2:
bind leftarrow moveleft
bind a p2moveleft
bind 1 p2weapon2
bind e p2weapon3
bind r p2weapon4
bind alt p2weapon5
bind 4 p2weapon6
bind capslock p2weapon7
bind tab p2weapon1
bind k p2lookup
bind h p2lookdown
bind j p2fire
bind w p2moveup
bind s p2movedown
bind a p2moveleft
bind d p2moveright
NOTE: Player's 1 binded lookup, lookdown keys will work if "mouselook 0" (type this command in console)

To bind mouse buttons use command "bind mbutton1 fire" "bind mbutton2 weapon6" "bind mbutton3 center".
Bind "Center" center the weapon look.
You create config to fast NFK setup. Just write all commands into file [your_config_name].cfg and place this file in basenfk directory of NFK catalogue. Type "exec your_config_name" in console and all Your config's commands will be applyed.
If you don't want to type "exec your_config_name" every time, You can create autoexec.cfg, and type "exec your_config_name" in it. Place autoexec.cfg in basenfk folder of NFK dierctory. Now your config will be loaded automatically.

Some more console commands:
unbindkeys
p2unbindkeys
p1defaultcontrols
p2defaultcontrols

CONSOLE COMMANDZ

 Key "~" toggles console.

bg [1-8] - background of the map.
crosscolor [1-7] - color of the crosshair of the player 1
p2crosscolor [1-7] - color of the crosshair of the player 2
crosstype [0-4] - type of the crosshair of the player 1
p2crosstype [0-4] - type of the crosshair of the player 2
fraglimit [0-999] - frag limitter
timelimit [0-999] - time limitter
quit - quit.
sensitivity [1-9] - mouse sensitivity (speed)
restart - restarts map. match begins again
drawfps [0-1] - number of frames per second. Must be always 50 for best play.
ready - begin the match - end of warmup
map - change map. for example "map dm2"
keybsensitivity [1-9] - a velocity (speed) of crosshair's movement, when play on keyboard.
keybaccelerate [0-9] - a accelerate of crosshair's movement, when play on keyboard (for player 1).
p2keybaccelerate [0-9] - a accelerate of crosshair's movement, when play on keyboard (for player 2).
warmup [1-999] - Time for preparation
railcolor [1-7] - a color of the railgun's ray for player 1
p2railcolor [1-7] - a color of the railgun's ray for player 2
bind - assing a key
exec - Execute config
unbindkeys - unbinds all controls for player 1.
p2unbindkeys - unbinds all controls for player 2.
railtrailtime [1-14] - time of railgun's ray extinction.
hitsound [0-1] - play hitsound when one player hits other
gibvelocity [0-1] - meat flies away in other side of hit side (not recommended).
gibblood [0-1] - gibs blood
disconnect - unloads the map and go back into menu.
stats - shows the statistics before the end of the game.
currenttime - shows current system time.
halfquit - use it, if "quit" command does not work.
record - begins demo record
stoprecord - ends demo record
demo - plays demo
doorsounds [0-1] - a sounds of the doors
cameratype [0-1] - a type of the camera (fixed\follow player 1)
mousesmooth - a limiter of mouse speed
gofullscreen - full screen mode
gowindow - window mode
weaponswitch_on_end [0-2] - auto switch of the weapon for player 1.
p2weaponswitch_on_end [0-2] - auto switch of the weapon for player 2.
model - model of the player 1 (model modelname+skinname)
p2model - model of the player 2
allowmapschangebg [0-1] - allow the map to change the background.
leavearena - unloads the map and go back into menu.
warmuparmor - an amount of armor in warmup.
shownick [0-1] - show name of the player.
autoshownick [0-1] - show name of the player (automatically).
autorecord - begins demo record (the name of demo is selected automatically)
mouselook [0-1] - (1)=player 1 looks on mouse; (0)=player 1 looks on keyboard.
corpsetime [0-60] - an amount of seconds, when dead body is situated on map. After this time it takes away.
forcerespawn [2-60] - a max amount of seconds when dead player can not respawn.
weapbartime [0-250] - - time to show weapon panel for player 1.
p2weapbartime [0-250] - - time to show weapon panel for player 2.
sndrestart - restart sound system.
midiplay - begin to play music from basenfk\music\*.mid
midinext - play next midi track.
midistop - stops midi music.
messagetime [0-500] - time to show one message.
log [0-1] - OFF\ON writing log file.
noplayer [0-2] - removes player. (0=all player exists) (1=no player 1) (2=no player 2). The Command works from the main menu only.
transparentstats [0-1] - (not) transparent statistics.
echo text - show the message "text".
menucolor [1-6] - menu color, which is caused by ESC button in playtime.
mp3play - nfkamp: begin to play mp3 from playlist.
mp3next - nfkamp: next track in playlist.
mp3stop - nfkamp: stop playing.
mp3reset - nfkamp: stop playing + playlist reload.
mp3volume - nfkamp: music volume level.
volume - volume of the game sounds.
speeddemo [0-40] - accelerate\decelerate demo's replay speed. Normal velocity is 20.
gauntletnextweapon - is gauntlet in list of weapons (nextweapon, prevweapon) of the player 1.
p2gauntletnextweapon - is gauntlet in list of weapons (nextweapon, prevweapon) of the player 2.
trixmasta - enabling the advanced trix arena mode. (in detail in "TRIX ARENA" section).
showmapinfo - [not] show the map information at the beginning of the gameplay
p1defaultcontrols - Throws player 1 controls to default.
p2defaultcontrols - Throws player 2 controls to default.
railarenainstagib [0-1] - instagib mode in railarena.
r_transparentbulletmarks [0-1] - transparent bullet marks.
r_flashingitems [0-1] - flashing medikits.
r_alphaitemsrespawn [0-1] - items appears using its alpha channel.
r_transparentexplosions [0-1] - transparent explosions.
r_railprogressivealpha [0-1] - itsa railgun setting. try both values. leave better one.
r_railsmooth [0-1] - smooth railtrail.
r_wateralpha [25-255] - grade of water tranparency.
r_drawbubbles [0-1] - draw bubbles?.
r_statusbaralpha [0-255] - grade of statusbar tranparency.
shownickatsb - show nicknames at the top of statusbarz
spectator [0-1] - toggles spectator mode (menu only, multiplayer only).
traffic - in\out traffic.
getplayersid - shows players ID.
kickplayer [ID] - Kick player (requires playerID).
sync [1-3] - client-server synchronization level.
m_invert [0-1] - mouse invert
m_rotated [0-1] - mouse Y axe changes to X axe
m_accelerate [0-15] - mouse acceleration.
net_coordinterpolate [0-100] - players coordinates smoothes (to avoid lag effect) (multiplayer only).
enemymodel - replaces enemy models to this model
ipaddress - Shows IP Address.
sv_allowjoinmatch [0-1] - Cliets can connect at any time (if enabled). Cliets can connect only at the warmup time (if disabled)
sv_dedicated [0-1] - Server with(out) server's player.
sv_hostname - host name.
nextplayer - switch to another player in the demo or in the spectator mode.
bar2assign [ID] - assigns statusbar2 to selected player (requires playerID).
drawfragbar - frags minipanel. multiplayer only.
fragbarx - frags minipanel position (x).
fragbary - frags minipanel position (y).
sv_lock - Makes commands "timelimit, fraglimit, forcerespawn, railarenainstagib, sync, sv_overtime, sv_teamdamage" read only. To remove lock you have to shutdown server.
sv_overtime [0-30] - Additional time if match is tied (teamplay only).
sv_teamdamage [0-1] - (not) hurt teammaters.
zoomwindow - stretches window to desktop size. (windowed mode only)
join red - join red team (teamplay only)
join blue - join blue team (teamplay only)
join auto - select's team automatically (teamplay only)
announcer [0-1]: score announcer, ("youre lost the lead" or "teams for tied" etc (it is sounds)).
teammodel [model+skin]: assign a specified model to your teammates.
cl_avidemo (number): consecutively screenshot saves to basenfk\ directory. With filename 0001.jpg. If (number) is specified, then nfk will start saving from (number).jpg.
sv_testplayer2: this command available only in multiplayer. It spawns second player at server. second player have player2 controls. It emulates hotseat in multiplayer, so, you can play with 3 players, with only 2 comps :) !
r_bgmotion [0-1]: Game background moves not synchronous with camera, it gives spatial effect. (only at big maps).
r_railstyle [0-4]: Style of rail ray.
fill_bgr [$AABBCC]: Background color fill (only with "drawbackground 0"). Where AA=blue, BB=green, CC=red. Example: "fill_bgr $0000FF" - fill with red. ($hex values). ch_conspeed [1-480]: Speed of console movement.
ch_conheight [64-480]: Maximum console height.
ch_conalpha [1-255]: Console's transparency level.
ch_constretch [0-1]: Console background stretching. (only with 040_CUSTOM_GRAFIX (read basenfk\custom\custom.txt)).
clear : Clear console (remove messages).
capturelimit : Limit of flag captures. (CTF Only)
domlimit : Limit of domination score
hidep2statusbar : Hide player2's statusbar.
r_markemptydeath [0-1]: Makes EMPTY and DEATH bricks visible.
r_fx_smoke [0-1]: FX: new 040 smoke
r_fx_rlbfg [0-1]: FX: rocket & bfg light.
r_fx_plasma [0-1]: FX: new 040 plasma.
r_fx_quad [0-1]: FX: quad player light.
r_fx_explo [0-1]: FX: explosions light (rg,gl,bfg).
cmdlist : Shows list of console commands.
say_team [text]: Send chat to your teammates (only teammates) (multiplayer team game only)
ch_dombarpos: DOMBAR Position (panel, which indicates status of Domination game) Y Axis
ch_dombarstyle [0-3]: Specify style of DOMBAR.
randommodels : Assign random models to all players.
ch_teambar_showmyself [0-1] - show my self in team bar?
ch_teambar_color [0-13] - color of TEAMBAR
ch_teambar_style [0-3] - font style of TEAMBAR.
cl_avimode [0-1]: 0 - cl_avidemo output is JPG. 1 - cl_avidemo output is BMP.
writeconfig: "writeconfig myconfig", current nfk setting will save to myconfig.cfg
nextwpn_skipempty [0-1]: if you choose next weapon by pressing "nextweapon" key, nfk will skip guns which doent have ammo.
p2nextwpn_skipempty [0-1]: same thing, but for player2.
ch_showrecordinglabel [0-1]: (dont) show "recording xxxx.ndm" label if recording demo.
connect xx.xx.xx.xx: nfk will connect to the specified ip address
sv_maxplayers [2-8]: maximum amout of players which allowed at this server
net_guaranteed [0-1]: packet lost prevention. Recommended to be always enabled.
net_predict [0-1]: nfk guesses player's position based on player's ping. Recommended to be enabled, expecially at dedicated servers.
minimize : minimizes nfk window.
ipinvite xx.xx.xx.xx: invites specified ip address to your server. Useful then connection is available only to one direction .
callvote consolecommand: Voting. You can toggle voting for some console command, and if number of positive (YES) votes will be enough to apply this command, it will be executed at server.
net_showbandwidth [0-1]: shows channel current bandwidth, bytes/sec (network).
vote [yes/no]: Vote YES or NO, if voting is active.
sv_allowvote [0-1]: Server allow voting.
sv_vote_percent [1-100]: If percent of positive votes is bigger than "sv_vote_percent" then command will be executed at server.
sv_allowvote_restart [0-1]: Server allow voting for "restart".
sv_allowvote_fraglimit [0-1]: Server allow voting for "fraglimit".
sv_allowvote_timelimit [0-1]: Server allow voting for "timelimit".
sv_allowvote_capturelimit [0-1]: Server allow voting for "capturelimit".
sv_allowvote_domlimit [0-1]: Server allow voting for "domlimit".
sv_allowvote_ready [0-1]: Server allow voting for "map".
sv_allowvote_map [0-1]: Server allow voting for "restart".
sv_allowvote_warmup [0-1]: Server allow voting for "warmup".
sv_allowvote_warmuparmor [0-1]: Server allow voting for "warmuparmor".
sv_allowvote_forcerespawn [0-1]: Server allow voting for "forcerespawn".
sv_allowvote_sync [0-1]: Server allow voting for "sync".
sv_allowvote_sv_teamdamage [0-1]: Server allow voting for "sv_teamdamage".
sv_allowvote_net_predict [0-1]: Server allow voting for "net_predict".
sv_allowvote_sv_maxplayers [0-1]: Server allow voting for "sv_maxplayers".
reconnect: reconnect to last known server.
r_altgrenades [0-1]: alternate granade's look.
ch_qwscoreboard [0-1]: Scoreboard in QuakeWorld style.
sv_powerup [0-1]: (dis)Allow powerups on this server.
sv_allowspectators [0-1]: (dis)Allow spectators on this server.
sv_maxspectators [1-4]: Maximum spectators count on this server.
sv_maxspectators [1-4]: Максимальное кол-во спектаторов на сервере.
h_exec executes cfg file, but without "execing.." message
ch_hudWidth HUD panel width. (big HUD).
ch_hudHeight HUD panel heigth.
ch_hudX HUD panel x pos.
ch_hudY HUD panel y pos.
ch_hudAlpha [0-255] HUD panel transparency level.
ch_hudIcons [0-1]: HUD panel icons.
ch_hudshadow [0-1]: HUD panel shadow.
ch_hudStretch [0-1]: HUD panel icons stretching.
ch_hudVisible [0-2]: HUD panel visible. 1-at big maps. 2-always.
rcon executes command at remote server.
rconpassword must be same at client and server, to enable "rcon".
sv_port [29991]: Server's port, do not change if you dont REALLY need to change it.
r_animatedarmors [0-1]: animated armors.
r_animatedmega [0-1]: animated megahealth.
nextmap next map from maplist.
sv_maplistfile : filename which contain map names for map cycler.
sv_mapcycle [0-1]: map cycler. Automatically changes map at match end.
r_fx_rail [0-1]: new railgun ray look
r_railwidth railgun ray width
toggleconsole toggle console.
gamma [0-20]: gamma.
r_massacre [0-5] : Ultra bloody MASSACRE mode! :)
modelslist : display list of models.
cg_swapskins [0-1]:changes teams colors (red-blue). Only visual effect. Your real team color is not changing.
messagemode: chat
messagemode2: team chat

If You enter the command without value, You'll see it's current value.

ITEMZ & REWARDZ

Weapons | Name | DMG
 | Gauntlet | dmg: 35.
 | Machine Gun | dmg: 5.
 | Shotgun | dmg: 7-75.
 | Grenade Launcher | dmg: 65.
 | Rocket Launcher | dmg: 80-100.
 | Lightning gun (Shaft) | dmg: 2-3.
 | Railgun | dmg: 75.
 | Plasma gun | dmg: 14.
 | BFG | dmg: 80-100.
Ammo | Name | Description
 | Bullets | Ammo for Machinegun.
 | Shells | Ammo for Shotgun.
 | Grenades | Ammo for Grenade Launcher.
 | Rockets | Ammo for Rocket Launcher.
 | Lightnings | Ammo for Lightning gun.
 | Slugs | Ammo for Rail gun.
 | Cells | Ammo for Plasma gun.
 | BFG ammo | Ammo for BFG.
Medikits | Name | Description
 | Medikit +5 | Adds 5 health.
 | Medikit +25 | Adds 25 health.
 | Medikit +50 | Adds 50 health.
 | Medikit +100 | Adds 100 health.
Armor | Name | Description
 | Shard | Adds 5 armor.
 | Yellow Armor | Adds 50 armor.
 | Red Armor | Adds 100 armor.
Artefacts | Name | Description
 | Fly | Ability to fly
 | Haste | Increases walk and fire speed
 | Battle Suit | Halfs received damage
 | Regeneration | Regenerates 5 health per second
 | Quad Damage | Increases inflicted damage in 3
 | Invisibility | Invisibility (multiplayer only)
Awards | Name | Description
 | Impressive | Earn for 3 no missed hits from railgun.
 | Excellent | Earn if in 2.5 seconds there was maded more than 1 frag.
 | Humiliation | Earn for gauntlet kill.

NFKAMP - MP3 Player

 NFK AMP - Built-in NFK mp3 Player. You need to create a playlist to listening mp3 music. Playlist - file, located in basenfk\music\mp3list.dat. It consist of full paths to mp3 files. There is program "playlist generator for NFKAMP" - for comfortable creation of playlists. It is located in basenfk\music\nfkamp.exe

NFKAMP commands:
mp3play - nfkamp: begin to play mp3 from playlist.
mp3next - nfkamp: next mp3 track.
mp3stop - nfkamp: stop any playing.
mp3reset - nfkamp: stop +playlist reload.
mp3volume - nfkamp: music volume.

TROUBLESHOOTING

 If some strange bugs appears then delete file nfkconfig.cfg in directory basenfk and start the game.
Possible problems:

Nfk dont want to start:
- U have pentium<=200.
- Game requires DirectX8.1
- Your video card doesn't support Direct3D8 mode.
- Some files from original supply are missed.

Nfk starts, but dont want to start map:
- Map have old format. Convert it via nfkradiant.
- Some files from original supply are missed.

to increase FPS try to run NFK in 16-bit graphic mode.

More TROUBLESHOOTING and FAQ you can find at http://www.3dpower.org

COMMAND LINE PARAMETERZ

 Parameters of command line enters as follows: "nfk.exe +parameter1" or "nfk.exe +parameter1 +parameter2 +parameter3".

Parameters:
+gowindow | Windowed mode.
+nosound | No sound.
+16bit | 16bit video mode.
+nfkplanet | Connect to nfk planet
+map | Load map
+game | Define gamedirectory
+dll | Load dll (+dll mybot.dll)
+connect | Connect to game (+connect x.x.x.x)
+exec | Load cfg (+exec cfgname)
+dontsavecfg | Do not save nfkconfig.cfg.
+demo | Start demo (+demo demoname)
+nonet | Disable detection of network parameters (enable if nfk loading is _really_ long)
+nogamma | Disable gamma control.

Example: "nfk.exe +gowindow +nosound".

Nfk supports game directories. You can put your file into 'mydir', and then "nfk.exe +game mydir". 'mydir' will works separately with basenfk folder.

Need For Kill © 3d[Power]
http://www.3dpower.org

Help file by 3d[Power], Baxxter, DJ Dimps, КАСПЕР, KAP^COH.
Design by Spike


============================
Need For Kill ver 040
Заметки о NFK040
(c) 3d[Power]
2003
http://www.3dpower.org
============================

CTF.
------------------------
* В нфк 040 добавлен новый сетевой режим игры Capture The Flag.
Прошу заметить что в режиме CTF игроки появляются не на обычных
RESPAWN позициях, а на REDRESPAWN и BLUERESPAWN позициях, в
зависимости от команды игрока. В других режимах игры, red respawn
и respawn blue не используются.
* CTF Бонусы: За захват флага игрок получает бонус 5 фрагов.
За возвращение своего флага на базу - бонус 1 фраг.
* При старте сервера в режиме CTF. sv_teamdamage (ранение
своих по команде) автоматически становится 0 (не ранятся).
* Лимит захватов флага регулируется консольной командой
"capturelimit"
* NFK не запустит режим CTF на карте, где неправильное кол-во
флагов или red\blu respawn'ов.
* fraglimit не учитывается
* В режиме игры CTF доступен TEAMBAR

DOMINATION
------------------------
* В нфк 040 добавлен новый сетевой режим игры Domination. Смысл игры:
Ваша команда должна захватить как можно больше dompoints (флаги в DOM).
Каждый dompoint приносит 0.33 фрага в секунду своей команде, т.е.
за 3 секунды команда получает 1 фраг (+1 to domscore). Количество
dompoints на карте: только 3!
* При старте сервера в режиме DOMINATION. sv_teamdamage 0. (нельзя ранить)
* Лимит dom score регулируется консольной командой "domlimit"
* NFK не запустит режим DOM на карте, где если dompoins <> 3
* fraglimit и timelimit не учитываются
* Dombar - панель, отображающая статус игры domination. Для настройки
dombar, есть 2 консольные команды "ch_dombarstyle", "ch_dombarpos"
* "ch_dombarstyle" [0-3]
0: Отключен
1: На панели 3 флага, каждый соответствует флагам в игре (с таким-же цветом).
2: Тоже что и "1", только флаги заменены на текст.
3: Один флаг, его цвет символизирует цвет доминирующей команды.
* "ch_dombarpos" [0-400]. Позиция панели по оси Y
* В режиме игры DOM доступен TEAMBAR

DROPPABLE WEAPONS
------------------------
* В нфк 040 из игроков (после смерти) вываливается оружие.
* При подбирании оружия, Вы получаете: во-первых само оружие :),
во-вторых, патроны (к текущему количеству патронов):
Shotgun +10
Grenade +5
Rocket +10
Shaft +130
Rail +10
Plasma +50
BFG +15
* Оружие не вываливаеся в режимах игры: TRIX, RAILARENA, PRACTICE
* Выпавшее оружие лежит минуту, потом исчезает.

NEW FX EFFECTS
------------------------
* В нфк 040 добавлены новые визуальные эффекты. Настройка этих
эффектов вынесена в консольные команды. По умолчанию все эффекты
включены. Команды:
r_fx_smoke - новый красивый дым (у ракет, гранат).
r_fx_rlbfg - свет от ракет, bfg.
r_fx_plasma - новая плазма.
r_fx_quad - свет от quad (player).
r_fx_explo - свет при взрывах (ракет, гранат, bfg).
* К новым эффектам можно отнести новые стили луча рэилгана. Которые
выбираются командой "r_railstyle" [0-4]

NEW CONSOLE COMMANDS
-----------------------
announcer [0-1]: комментатор текущего счета , говорит "youre lost the lead" или "teams for tied" итд.
teammodel [model+skin]: назначает вашим тиммэйтерам выбранную модель.
cl_avidemo (number): последовательно сохраняет скриншоты в basenfk\. с именем 0001.jpg. Если указан параметр (number) то файлы будут создаваться начиная с (number), например "cl_avidemo 1000", или "cl_avidemo" (с 0).
sv_testplayer2: мультиплеерная команда. На сервере создается второй игрок. Его управление от player2 в hotseat.
r_bgmotion [0-1]: Бэкграунд движется не синхронно с картой (пространственный эффект). Только на больших картах).
r_railstyle [0-4]: Стиль луча рэилгана.
fill_bgr [$AABBCC]: Заливка заднего фона, (при "drawbackground 0"). Где AA=синий. BB-зеленый. CC-красный. Например: "fill_bgr $0000FF" - заливка красным цветом. (значения в шестнадцатеричной системе)
ch_conspeed [1-480]: Cкорость выдвижения консоли.
ch_conheight [64-480]: высота консоли (максимальное расстояние на которое может выдвинуться консоль).
ch_conalpha [1-255]: Степень прозрачности консоли.
ch_constretch [0-1]: Растяжение бэкграунда консоли. (только при подключенной 040_CUSTOM_GRAFIX)
clear : Очищает консоль от всех надписей.
capturelimit : Лимит захватов флага (CTF Only)
domlimit : Лимит очков в режиме игры Domination.
hidep2statusbar : Убирает статусбар игрока2.
r_markemptydeath [0-1]: Делает death и empty брики видимыми.
r_fx_smoke [0-1]: Спец эффект: новый дым
r_fx_rlbfg [0-1]: Спец эффект: свет от ракет, bfg.
r_fx_plasma [0-1]: Спец эффект: новая плазма.
r_fx_quad [0-1]: Спец эффект: свет от quad (player).
r_fx_explo [0-1]: Спец эффект: свет при взрывах (ракет, гранат, bfg).
cmdlist : Выводит список всех консольных команд.
say_team [text]: отправить чат только своим по команде (multiplayer team game only)
ch_dombarpos: Позиция DOMBAR (панель отображающая статус игры Domination) по оси Y
ch_dombarstyle [0-3]: Внешний вид DOMBAR.
randommodels : Всем игрокам ставит рандомные модели (из доступных).
ch_teambar_showmyself [0-1] - показывать себя в TEAMBAR..
ch_teambar_color [0-13] - цвет TEAMBAR
ch_teambar_style [0-3] - стиль TEAMBAR.
cl_avimode [0-1]: 0 - cl_avidemo записывает в jpg. 1 - cl_avidemo записывает в bmp.
writeconfig: "writeconfig myconfig", в файл myconfig.cfg будут записаны текущие настройки нфк.
nextwpn_skipempty [0-1]: при выборе оружия, через nextweapon и prevweapon, не будут выбираться оружия без патронов.
p2nextwpn_skipempty [0-1]: тоже самое, только для игрока2.
ch_showrecordinglabel [0-1]: (не) показывать вверху экрана надпись "recording xxxx.ndm", в случае записи демки.

NFK CUSTOM GRAFIX
-------------------
* В нфк 040 некоторую графику можно заменять на свою. А конкретно: подложка под консоль,
бэкграунды, подложка под статистику.
* Чтобы установить свою графику вам нужно создать файл в формате jpg, и положить сюда:
basenfk\custom\console.jpg
basenfk\custom\bg_1.jpg
basenfk\custom\bg_2.jpg
basenfk\custom\bg_3.jpg
basenfk\custom\bg_4.jpg
basenfk\custom\bg_5.jpg
basenfk\custom\bg_6.jpg
basenfk\custom\bg_7.jpg
basenfk\custom\bg_8.jpg
basenfk\custom\stats.jpg
* Разрешения jpg файлов. В принципе любое, но вот рекомендованные разрешения:
console.jpg - 320x200
bg_x.jpg - 256x256
stats.jpg - 256x256
(максимальный размер текстуры зависит от возможностей вашей видео карты)
* При использовании custom backgrounds рекомендую поставить "allowmapschangebg 0".
(запретить картам менять задний фон).


Tribes X

Tribes X 1.9b

HOTSEAT

Режим HOTSEAT (игра вдвоем за одним компьютером).
Слева вверху список карт. Справа, настройки игры. Там же можно изменить свойства игроков. 1ый игрок играет на мышке. 2ой игрок играет на клавиатуре. Управление можно переназначить.

В настройки матча входят 4 параметра "warmup, fraglimit,timelimit,gametype". Warmup - время на подготовку перед матчем. Fraglimit - Ограничение по фрагам. Timelimit - Ограничение по времени. Gametype - тип игры (deathmatch, rail arena, practice).Рекомендуемые (стандартные) настройки для игры 1v1 это: warmup 180; fraglimit 0; timelimit 10.

Чтобы начать игру, нажмите "fight". Когда загрузилась карта и начался отчет, можно на консоли набрать команду "ready" (или нажать F10) которая начнет матч без разыгровки. В HOTSEAT можно играть в типы игры: DeathMatch, Rail Arena, Practice.

BOTS

В поставку Tribes входит NapBot, чтобы играть с ботом, нужно выдвинуть консоль (нажав кнопку ~), ввести "addbot", без кавычек. Все, можно играть. Стандартные ботовые консольные команды: addbot, removebot, addredbot, addbluebot и т.д.
Примечание: Подключать других ботов нельзя, да и в этом нет необходимости.

MULTIPLAYER

Многопользовательский режим. Поддерживается до 4 игроков и 4 ботов, всего 8 (в противном случае игра зависает)
Сетевая игра в Tribes возможна как по интернету, так и по локальной сети. Для игры по интернету необходимо выбирать пункт Tribes PLANET в окне MULTIPLAYER. Чтобы "создать" игру, то есть стать хостом - нужно нажать кнопку CREATE, после чего выбрать карту, и прочие настройки:
Сначала выберите карту на которой будете играть. Потом сконфигурируйте настройки сервера:
Hostname - Название Вашего сервера
Allow Join Match - Клиенты могут подсоединяться в любое время, если выключено, то только вармапе.
Dedicated - Yes=сервер будет создан без серверных игроков.
Synchronization - Степень синхронизации данных между клиентом и сервером. На быстрых соединениях (LAN) нужно ставить Heavy, на более медленных Medium или Light. Параметр Synchronization уменьшает увеличивает сетевой трафик.
Учтите что не рекомендуется будучи пользователем модема создавать игры на 8 человек по интернету..

Подсодинение к уже созданной игре: В списке найденных серверов, выбрать нужный сервер и нажать FIGHT.
Чтобы стать наблюдателем, нужнно ввести консольную команду "spectator 1". Вводится в меню, перед подсоединением к серверу. (На сервере должны быть разрешены спектаторы (sv_allow_spectators 1)).
Чат:
По умолчанию, чат на кнопке ENTER. Если хотите повесить его на другую кнопку, то используйте следующую консольную команду (bind enter messagemode). Для командного чата, команда messagemode2.
А также можно чатить прямо с консоли, набрав текст сообщения и нажав CTRL+ENTER.

Цветные имена:
Tribes поддерживает цветные имена (не только по мультиплееру). Форма записи имен такая же как в Quake3. То есть нужно в имени написать тэг, который означает цвет. Доступны следующие цвета: 1234567. Перед номером нужно ставить символ "^". Примеры:
^1pla^3y^1er - player.
Еще есть тэг "^b", он делает текст мигающим, а тэг "^n" останавливает мигание.
Примечание: максимальная длина имени это 30 символов.

Голосование (voting):
Присутствует возможность голосования (callvote) в мультиплеерных играх. Можно выдвигать на голосование выбранную консольную команду, по проценту проголосовавших ЗА, выбирается, будет ли применена команда.
Возможно голосовать за конс команды: restart, ready, map, fraglimit, timelimit, capturelimit, domlimit, warmup,warmuparmor, forcerespawn, sync, sv_teamdamage, net_predict, sv_maxplayers.
Пример: "callvote restart", "callvote map tourney4". Подробнее читайте о консольных командах, относящихся к голосованию, в разделе CONSOLE.

В MULTIPLAYER можно играть в типы игры: DeathMatch, Teamplay, Rail Arena, Practice, Capture The Flag, Domination

GAMETYPES

 Типы игры. Tribes поддерживает 7 типов игры: DeathMatch, Practice, Rail Arena, Team Play, Capture The Flag, Domination, Trick Arena.

DeathMatch
В этом режиме игроки играют каждый сам за себя. Можно играть как вдвоем, так и толпой.
* Действующие лимиты: fraglimit, timelimit
* Доступен в: Hotseat, Multiplayer

Practice
Тоже что и DeathMatch. Отличается тем, что игроки стартуют со всеми оружиями, 200 hp, и 200 брони.
* Действующие лимиты: fraglimit, timelimit
* Доступен в: Hotseat, Multiplayer

Rail Arena
Битва только на RailGun. Все предметы с карты убираются. При респавне игроки уже имеют при себе RailGun.
* Действующие лимиты: fraglimit, timelimit
* Доступен в: Hotseat, Multiplayer

Team Play
Командная игра. Игроки делятся на две команды, синяя и красная. За убийство своего напарника, команда теряет один фраг. Количество фрагов у команды равно сумме фрагов членов команды.
* Действующие лимиты: fraglimit, timelimit
* Доступен в: Multiplayer
* sv_teamdamage (ранение своих по команде): 1 (ранятся).
* В этом режиме игры доступна специальная панель TEAMBAR (Отображает Ваш статус и ваших напарников). Консольные команды по настройке TEAMBAR смотрите в разделе Console Commands, команды начинаются с "ch_teambar....".

Capture The Flag
Командная игра. Цель игры: взять вражеский флаг, и принести его к себе на базу (ваш флаг должен там присутствовать). За захват флага ваша команда получает одно capture point. Команда, которая набрала больше capture points - победила.
* Действующие лимиты: capturelimit, timelimit
* Доступен в: Multiplayer
* CTF Бонусы: За захват флага игрок получает бонус 5 фрагов. За возвращение своего флага на базу - бонус 1 фраг.
* sv_teamdamage (ранение своих по команде): 0 (не ранятся).
* В этом режиме игры доступна специальная панель TEAMBAR.

Domination
Командная игра. Есть несколько контрольных точек (dom point). Цель - получить контроль над этими точками (пройти через них, в результате чего их цвет поменяется на цвет вашей команды) и не потерять его. Очки (dom score) зарабатываются за каждую секунду, когда ваша команда контролирует эти точки. Команда набравшая большее количество очков (dom score), побеждает.
* Действующие лимиты: domlimit, timelimit
* Доступен в: Multiplayer
* sv_teamdamage (ранение своих по команде): 0 (не ранятся).
* В этом режиме игры доступна специальная панель TEAMBAR.
* В этом режиме игры доступна специальная панель "DOMBAR" (Отображает статус игры domination). Консольные команды по настройке DOMBAR смотрите в разделе Console Commands, команды начинаются с "ch_dom....".

Trix Arena
Одиночный режим игры. Суть которого пройти trick карту за наименьшее время. На www.3dpower.org располагается таблица рекордов для триковых карт. Чтобы принять участие в Trix Arene вам надо пройти карту за время которое может войти в таблицу и прислать демку мне на мыло. Убедительная просьба, демы архивировать.
Требования к демке: Имя игрока должно быть Ваше. Демка должна начинаться с вармапа. Название файла: картa_время_ник. (trick1_20_04s_power).
Существует удобная система для прохождения карты и записи демы под trix arena. Включается этот режим консольной командой "trixmasta 1".
В этом режиме:
- Вармап автоматически 5 сек.
- При старте карты, дема начинает сама записываться.
- При смерти игрока делается рестарт и запись демы.
- При нажатии на кнопку F12 делается рестарт и запись демы.
- При завершении карты, Tribes сам называет демку [карта]+[время]+[ник].
* Действующие лимиты: нет
* Доступен в: Hotseat

Заметки для мапмэйкеров:
* CAPTURETHEFLAG: В режиме CTF игроки появляются не на обычных RESPAWN позициях, а на REDRESPAWN и BLUERESPAWN позициях, в зависимости от команды игрока. В других режимах игры, red respawn и respawn blue не используются.
* DOMINATION: Tribes не запустит режим DOMINATION на карте, где dompoints <> 3

MODELS

 В Tribes можно играть разными моделями. Модели Tribes - это внешний вид игрока. Установка модели: все модели хранятся в каталоге с игрой в папке basenfk\models\ . К примеру, Вы скачали модель klesk. Папку klesk из архива klesk.zip переписываете в каталог с игрой в папку basenfk\models\ . После чего модель станет доступной в списках моделей.
Дополнительные модели можно скачать с http://Tribes.pqr.ru
Выбирать модель можно через окно player properties или через консольную команду "model klesk+blue","p2model klesk+blue". Теоретически вы можете создавать свои модели.

DEMOS

 В игре можно демы писать\проигрывать. Чтобы начать запись надо сначала стартовать игру (на карте). и написать команду "record mydemo1" или "autorecord". Когда матч закончится демка остановиться сама, но если вы хотите завершить запись до конца матча, то надо набрать "stoprecord". Проиграть демку можно из главного меню, в разделе DEMOS или консольной командой "demo mydemo1".
Примечание: Если вы записываете демку будучи клиентом, то желательно чтобы вы ее записали полностью, от начала до конца партии, если вы ее прервете, то статистика игры не будет записана, так как она приходит с сервера в конце партии.

Ускорение \ замедление скорости проигрывания демки, можно регулировать кнопками num- num+

BINDINGS

 УЧТИТЕ: что нельзя биндить сериями команд (например bind space "fire; nextweapon; kill") Чтобы набиндить кнопку нужно написать:
bind {key} {action}
Ниже описано каким может быть параметр {key}
A,B,C,D....Z
1,2,3..0
shift, ctrl, alt, tab, space, capslock, num0, num1, num2, num3, num4, num5, num6, num7, num8, num9, num0, num/, num*, num-, num+, num., enter, insert, home, pgup, pgdown, delete, end, backspace, leftarrow, rightarrow, uparrow, downarrow,
mbutton1,mbutton2,mbutton3 - кнопки мыши.
Ниже описано каким может быть параметр {action}:
moveleft, moveright, moveup, movedown, nextweapon, prevweapon, lookup, lookdown, fire, center, weapon0, weapon1, weapon2, weapon3, weapon4, weapon5, weapon6, weapon7, weapon8, p2moveleft, p2moveright, p2moveup, p2fire, p2nextweapon, p2prevweapon, p2lookup, p2lookdown, p2center, p2weapon0, p2weapon1, p2weapon2, p2weapon3, p2weapon4, p2weapon5, p2weapon6, p2weapon7, p2weapon8, scoreboard.

Пример как биндить:
bind leftarrow moveleft
bind a p2moveleft
приставка p2 значит для второго игрока. Ниже приложен пример набиндивания управления для игрока 2:
bind 1 p2weapon2
bind e p2weapon3
bind r p2weapon4
bind alt p2weapon5
bind 4 p2weapon6
bind capslock p2weapon7
bind tab p2weapon1
bind k p2lookup
bind h p2lookdown
bind j p2fire
bind w p2moveup
bind s p2moveup
bind a p2moveleft
bind d p2moveright
 NOTE: Чтобы забинденные значения lookup, lookdown работали то надо на консоли набрать "mouselook 0", и тогда смотрение игрока 1 будет на забинденных кнопках со значениями lookup, lookdown.

Чтобы биндить мышь надо "bind mbutton1 fire" "bind mbutton2 weapon6" и тд.
Бинд "Center" центрует оружие.
Чтобы записать бинды в отдельный конфиг перенесите команды в отдельный cfg файл. И потом вызывайте его в главном меню (на консоли набрать "exec yourfilename". Yourfilename.cfg должен лежать в каталоге basenfk).
Если вас ломает каждый раз писать EXEC, то в каталоге basenfk создайте конфиг autoexec.cfg, а в нем напишите exec Yourfilename. И ваш конфиг будет грузиться автоматом.

Консольные, команды относящиеся к биндам: unbindkeys
p2unbindkeys
p1defaultcontrols
p2defaultcontrols

CONSOLE COMMANDS

 Консоль вызывается кнопкой "~"

bg [1-8] - изменяет задний фон карты.
crosscolor [1-7] - Цвет прицела игрока 1
p2crosscolor [1-7] - Цвет прицела игрока 2
crosstype [0-4] - Вид прицела игрока 1
p2crosstype [0-4] - Вид прицела игрока 2
fraglimit [0-999] - Ограничение по фрагам
timelimit [0-999] - Ограничение по времени
quit - выход.
sensitivity [1-9] - cкорость мыши
restart [0-1] - перезагружается карта. Матч начинается сначала.
drawfps [0-1] - показывает колво фреймов. Должно быть всегда 50. Это ограничение такое.
ready - начать матч
map - Сменить карту. например "map dm1"
keybsensitivity [1-9] - Скорость look'a с клавиатуры.
keybaccelerate [0-9] - Акселерация look'a с клавиатуры (игрока 1).
p2keybaccelerate [0-9] - Акселерация look'a с клавиатуры (игрока 2).
warmup [1-999] - Время на подготовку.
railcolor [1-7] - Цвет луча рэилгана игрока 1
p2railcolor [1-7] - Цвет луча рэилгана игрока 2
bind - Назначить клавишу
exec - Выполнить конфиг
unbindkeys - отбиндивает управление 1.
p2unbindkeys - отбиндивает управление 2.
railtrailtime [1-14] - время остывания луча рэила.
hitsound [0-1] - при удачном попадании проигрывается звук hitsnd.wav.
gibblood [0-1] - кровь от мяса.
disconnect - выгружает карту и возвращает в меню.
currenttime - показывает текущее время.
halfquit - юзай если quitom не выходит.
record - начинается запись демки
stoprecord - заканчивается запись демки
demo - проигрывает дему
doorsounds [0-1] - звуки дверей
cameratype [0-1] - тип камеры (неподвижная\за игроком).
mousesmooth - ограничитель скорости мыши
gofullscreen - на полный экран
gowindow - оконный режим
weaponswitch_on_end [0-2] - авто смена оружия игрока1.
p2weaponswitch_on_end [0-2] - авто смена оружия игрока2.
model - модель игрока 1
p2model - модель игрока 2
allowmapschangebg [0-1] - разрешить картам менять задний фон.
leavearena - выгружает карту и возвращает в меню.
warmuparmor - количество армора в разыгровке.
shownick [0-1] - показывать ник над игроком.
autoshownick [0-1] - показывать ник над игроком (автоматически).
autorecord - начинается запись демки (имя демки придумывается за вас)
mouselook [0-1] - 1=игрок 1 смотрит на мыше; 0=на клаве.
corpsetime [0-60] - кол-во сек трупа. после этого времени он убирается.
forcerespawn [2-60] - макс кол-во сек на лежание трупом.
weapbartime [0-250] - время подсветки панели оружий игрока1.
p2weapbartime [0-250] - время подсветки панели оружий игрока2.
sndrestart - пере инициализация звука.
midiplay - начать проигрывать музыку. из basenfk\music\*.mid
midinext - следующий трэк.
midistop - остановить музыку.
messagetime [0-500] - время на показ одного сообщения.
log [0-1] - выключает\включает запись лог файла.
noplayer [0-2] - (0=2 игрока) (1=нет игрока 1) (2=нет игрока 2). Команда работает только из главного меню и только в хотсите.
transparentstats [0-1] - (не) прозрачная статистика.
echo text - выводит сообщение text.
menucolor [0-13] - Цвет меню, которое вызывается по кнопке ESC в игре.
mp3play - NFKamp: начать проигрывать mp3 из плей листа.
mp3next - NFKamp: следующий трэк к плэйлисте.
mp3stop - NFKamp: стоп.
mp3reset - NFKamp: стоп + перезагрузка плейлиста.
mp3volume - громкость музыки.
volume - громкость звука.
speeddemo [0-40] - ускорение\замедление проигрывания демки. Нормальная скорость: 20.
gauntletnextweapon - gauntlet есть\нет в списке nextweapon(prevweapon) игрока 1.
p2gauntletnextweapon - gauntlet есть\нет в списке p2nextweapon(p2prevweapon) игрока 2.
trixmasta - включение продвинутого режима trix arena. (подробнее в разделе TRIX ARENA).
showmapinfo - [не]показывать информацию о карте в начале партии.
p1defaultcontrols - Сбрасывает управление игрока 1 на изначальные значения.
p2defaultcontrols - Сбрасывает управление игрока 2 на изначальные значения.
railarenainstagib [0-1] - режим instagib в railarena.
r_transparentbulletmarks [0-1] - Прозрачные отпечатки на стенах от machine gun, shotgun.
r_flashingitems [0-1] - Аптечки и поверапы плавно меняют яркость.
r_alphaitemsrespawn [0-1] - При респавне предметы плавно появляются из ниоткуда.
r_transparentexplosions [0-1] - Прозрачные взрывы.
r_railprogressivealpha [0-1] - Настройка рэила. Зависит от railtrailtime, как по симпатичней будет так и оставьте.
r_railsmooth [0-1] - смазанный рэил.
r_wateralpha [25-255] - степень прозрачности воды\лавы.
r_drawbubbles [0-1] - отрисовка пузырей, при плавании.
r_statusbaralpha [0-255] - степень прозрачности статус бара.
shownickatsb - Показывать ники над статусбарами.
spectator [0-1] - Вводится в меню, перед подсоединением к серверу, при значении 1 вы становитесь спектатором (наблюдателем).
traffic - показывает входящий\исходящий траффик.
getplayersid - выводит ID игроков.
kickplayer [ID] - Выпинывает игрока с сервера (нужно указать ID игрока).
sync [1-3] - степень синхронизации между клиентом\сервером. на лане ставьте 1 (сильная). 2-средняя. 3-слабая.
m_invert [0-1] - реверс мыши
m_rotated [0-1] - чтобы смотреть, нужно крутить мышь не вверх\вниз а влево\вправо.
m_accelerate [0-15] - акселерация мыши
net_coordinterpolate [0-100] - степень сглаживания координат (во избежании "лагания" игроков). (по мультиплееру).
enemymodel - замена моделей врагов на указанную. (вводится в меню)
ipaddress - показывает локальный IP Address.
sv_allowjoinmatch [0-1] - 1-Разрешает присоединяться к серверу в любое время; 0-только в вармапе.
sv_dedicated [0-1] - сервер без серверных игроков
sv_hostname - хост нэйм.
nextplayer - в демке или в режиме спектатора слежение переходит за следующим игроком.
bar2assign [ID] - только в демке. назначает 2ой статус бар указанному игроку (нужно указать ID игрока).
drawfragbar - панелька с фрагами. только по мультиплееру.
fragbarx - позиция X панельки с фрагами.
fragbary - позиция Y панельки с фрагами.
sv_lock - Запрещает изменение команд "timelimit, fraglimit, forcerespawn, railarenainstagib, sync, sv_teamdamage, sv_overtime". Снять lock можно только если закрыть сервер.
sv_overtime [0-30] - Количество добавочных минут при ничьей в режиме игры teamplay.
sv_teamdamage [0-1] - (не) ранить своих тиммэйтеров.
zoomwindow - растяжение экрана до размеров десктопа (в оконном режиме)
join red - присоединиться к красной команде. (teamplay only)
join blue - присоединиться к синей команде. (teamplay only)
join auto - Tribes сам выбирает вам команду. (teamplay only)
announcer [0-1]: комментатор текущего счета , говорит "youre lost the lead" или "teams for tied" и тд.
teammodel [model+skin]: назначает вашим тиммэйтерам выбранную модель.
cl_avidemo (number): последовательно сохраняет скриншоты в basenfk\. с именем 0001.jpg. Если указан параметр (number) то файлы будут создаваться начиная с (number), например "cl_avidemo 1000", или "cl_avidemo" (с 0).
sv_testplayer2: мультиплеерная команда. На сервере создается второй игрок. Его управление от player2 в hotseat.
r_bgmotion [0-1]: Бэкграунд движется не синхронно с картой (пространственный эффект). Только на больших картах).
r_railstyle [0-4]: Стиль луча рэилгана.
fill_bgr [$AABBCC]: Заливка заднего фона, (при "drawbackground 0"). Где AA=синий. BB-зеленый. CC-красный. Например: "fill_bgr $0000FF" - заливка красным цветом. (значения в шестнадцатеричной системе)
ch_conspeed [1-480]: Cкорость выдвижения консоли.
ch_conheight [64-480]: высота консоли (максимальное расстояние на которое может выдвинуться консоль).
ch_conalpha [1-255]: Степень прозрачности консоли.
ch_constretch [0-1]: Растяжение бэкграунда консоли. (только при подключенной 040_CUSTOM_GRAFIX)
clear : Очищает консоль от всех надписей.
capturelimit : Лимит захватов флага (CTF Only)
domlimit : Лимит очков в режиме игры Domination.
hidep2statusbar : Убирает статусбар игрока2.
r_markemptydeath [0-1]: Делает death и empty брики видимыми.
r_fx_smoke [0-1]: Спец эффект: новый дым
r_fx_rlbfg [0-1]: Спец эффект: свет от ракет, bfg.
r_fx_plasma [0-1]: Спец эффект: новая плазма.
r_fx_quad [0-1]: Спец эффект: свет от quad (player).
r_fx_explo [0-1]: Спец эффект: свет при взрывах (ракет, гранат, bfg).
cmdlist : Выводит список всех консольных команд.
say_team [text]: отправить чат только своим по команде (multiplayer team game only)
ch_dombarpos: Позиция DOMBAR (панель отображающая статус игры Domination) по оси Y
ch_dombarstyle [0-3]: Внешний вид DOMBAR.
randommodels : Всем игрокам ставит рандомные модели (из доступных).
ch_teambar_showmyself [0-1] - показывать себя в TEAMBAR..
ch_teambar_color [0-13] - цвет TEAMBAR
ch_teambar_style [0-3] - стиль TEAMBAR.
cl_avimode [0-1]: 0 - cl_avidemo записывает в jpg. 1 - cl_avidemo записывает в bmp.
writeconfig: "writeconfig myconfig", в файл myconfig.cfg будут записаны текущие настройки Tribes.
nextwpn_skipempty [0-1]: при выборе оружия, через nextweapon и prevweapon, не будут выбираться оружия без патронов.
p2nextwpn_skipempty [0-1]: то же самое, только для игрока2.
ch_showrecordinglabel [0-1]: (не) показывать вверху экрана надпись "recording xxxx.ndm", в случае записи демки.
connect xx.xx.xx.xx: Tribes присоединяется в созданную игру по ип xx.xx.xx.xx
sv_maxplayers [2-8]: Максимальное количество игроков, которые могут играть на этом сервере.
net_guaranteed [0-1]: Контроль потери пакетов (packet lost). Рекомендуется держать всегда включенным.
net_predict [0-1]: Предугадывание позиции игрока основываясь на пинге. Рекомендуется включать, особенно на выделенных серверах.
minimize : Минимизирует Tribes.
ipinvite xx.xx.xx.xx: Кидает приглашение в игру по указанному IP адресу. Полезно если соединение устанавливается только в одну сторону.
callvote consolecommand: Голосование. Можно выдвигать на голование выбранную консольную команду, по проценту проголосовавших ЗА, выбирается, будет ли применена команда.
net_showbandwidth [0-1]: Показывает прокачку (загруженность канала). bytes \ sec.
vote [yes/no]: Голос ЗА или ПРОТИВ, при активном голосовании.
sv_allowvote [0-1]: На сервере разрешено голосование.
sv_vote_percent [1-100]: Голосование принимается если процент проголосовавших больше чем sv_vote_percent%
sv_allowvote_restart [0-1]: На сервере разрешено голосование за "restart".
sv_allowvote_fraglimit [0-1]: На сервере разрешено голосование за "fraglimit".
sv_allowvote_timelimit [0-1]: На сервере разрешено голосование за "timelimit".
sv_allowvote_capturelimit [0-1]: На сервере разрешено голосование за "capturelimit".
sv_allowvote_domlimit [0-1]: На сервере разрешено голосование за "domlimit".
sv_allowvote_ready [0-1]: На сервере разрешено голосование за "map".
sv_allowvote_map [0-1]: На сервере разрешено голосование за "restart".
sv_allowvote_warmup [0-1]: На сервере разрешено голосование за "warmup".
sv_allowvote_warmuparmor [0-1]: На сервере разрешено голосование за "warmuparmor".
sv_allowvote_forcerespawn [0-1]: На сервере разрешено голосование за "forcerespawn".
sv_allowvote_sync [0-1]: На сервере разрешено голосование за "sync".
sv_allowvote_sv_teamdamage [0-1]: На сервере разрешено голосование за "sv_teamdamage".
sv_allowvote_net_predict [0-1]: На сервере разрешено голосование за "net_predict".
sv_allowvote_sv_maxplayers [0-1]: На сервере разрешено голосование за "sv_maxplayers".
reconnect: Переподсоединиться к прошлому\текущему серверу.
r_altgrenades [0-1]: Альтернативный внешний вид гранат.
ch_qwscoreboard [0-1]: Таблица с фрагами в стиле QuakeWorld.
sv_powerup [0-1]: Разрешает\запрещает поверапы на сервере.
sv_allowspectators [0-1]: Разрешает\запрещает спектаторов на сервере.
sv_maxspectators [1-4]: Максимальное кол-во спектаторов на сервере.
h_exec Выполняет конфиг, то же что и exec, только не выводится надпись "execing.."
ch_hudWidth Ширина HUD панели. (HUD тот, что большой).
ch_hudHeight Высота HUD панели.
ch_hudX Позиция по Х HUD панели.
ch_hudY Позиция по Y HUD панели.
ch_hudAlpha [0-255] степерь прозрачности HUD панели.
ch_hudIcons [0-1]: показывать ли иконки на hud панели.
ch_hudshadow [0-1]: рисовать ли тень под hud панелью.
ch_hudStretch [0-1]: растягивать ли иконки hud панель.
ch_hudVisible [0-2]: показывать ли hud панель. 1-только на больших картах. 2-всегда.
rcon выполняет команду на удаленном сервере.
rconpassword должен быть одинаковый на сервере и на клиенте, чтобы с клиента работала "rcon".
sv_port [29991]: Порт сервера, без особых причин, менять не рекомендуется.
r_animatedarmors [0-1]: анимированные арморы.
r_animatedmega [0-1]: анимированная мега.
nextmap следующая карта из maplist.
sv_maplistfile: имя файла откуда maplist берет имена карт.
sv_mapcycle [0-1]: автоматическая смена карты на сервере, по окончанию партии.
r_fx_rail [0-1]: новый внешний вид луча railgun'a
r_railwidth толщина луча railgun'a
toggleconsole вызывает консоль.
gamma [0-20]: гамма.
r_massacre [0-5]: кровавый режим MASSACRE! стекающая кровь по стенам. :)
modelslist : выводит на консоль список загруженных моделей.
cg_swapskins [0-1]: меняет цвета моделек в командной игре (red<->blue). Только визуально, физически команды остаются прежними.
messagemode: чат
messagemode2: командный чат

Если ввести команду без значения, то будет показано ее текущее значение.

Всё что описанно выше, это конечно интересно, но в текущей версии их немного прибавилось и ТАГ поехали:

x-fly: дает возможность летать (только на Sky картах).
x-land: отнимает возможность летать (только на Sky картах).
x-kill: самоубийство (только на Ast картах в режиме CTF и только у красной команды).
put_brick [x,y,id]: добавляет бак-брик указанного id цвета.
put_water [x1,y2,x2,y2]: добавляет блок воды.
put_death [x,y]: добавляет дэд-брик.
del_brick [x,y]: удаляет брик.
img_brick [old id,new id]: кажись меняет указанный id old цвет брика на новый new id.
region_brick [x1,y2,x2,y2,id]: добавляет блок бриков id цвета.
brickreplace [id]: заменить все брики на карте на указанные id.
red_point [x,y]: добавляет красный респаун (только на Ast картах в режиме CTF).
blue_point [x,y]: добавляет синий респаун (только на Ast картах в режиме CTF).
clear_point [x,y]: удаляет все красные/синие респауны на карте (только на Ast картах в режиме CTF).
del_point [x,y]: удаляет красный/синий респаун (только на Ast картах в режиме CTF).
xsnd_on: разрешает использование посторонних звуков (крики и вопли издаваемые командой say ^!^).
xsnd_off: запрещает использование посторонних звуков (крики и вопли издаваемые командой say ^!^).
xkill_on: разрешает самоубийство по команде x-kill (только на Ast картах в режиме CTF и только у красной команды).
xkill_off: запрещает самоубийство по команде x-kill (только на Ast картах в режиме CTF и только у красной команды).
ultra_mode: включает режим использования nfo файлов к картам, дает возможность
ипользовать конфиг/саунд/месаг тригеры.
exec_script [x]: выполнить скрипт.
+ wait [x]: приостановить выполнение скрипта на определённое время (1сек = 1000).
+ waittarget [x]: остановить выполнение скрипта, до активации тригера.
+ execonce [0-1]: 0 - зациклить, 1 - использовать скрипт только один раз.

ITEMS & REWARDS

Оружие | Название | ДМГ
 | Gauntlet | дмг: 35.
 | Machine Gun | дмг: 5.
 | Shotgun | дмг: 7-75.
 | Grenade Launcher | дмг: 65.
 | Rocket Launcher | дмг: 80-100.
 | Lightning gun (Shaft) | дмг: 2-3.
 | Railgun | дмг: 75.
 | Plasma gun | дмг: 14.
 | BFG | дмг: 80-100.
Патроны | Название | Описание
 | Bullets | Патроны к Machinegun.
 | Shells | Патроны к Shotgun.
 | Grenades | Патроны к Grenade Launcher.
 | Rockets | Патроны к Rocket Launcher.
 | Lightnings | Патроны к Lightning gun.
 | Slugs | Патроны к Rail gun.
 | Cells | Патроны к Plasma gun.
 | BFG ammo | Патроны к BFG.
Аптечки | Название | Описание
 | Medikit +5 | Добавляет 5 хелса.
 | Medikit +25 | Добавляет 25 хелса.
 | Medikit +50 | Добавляет 50 хелса.
 | Medikit +100 | Добавляет 100 хелса.
Броня | Название | Описание
 | Shard | Добавляет 5 брони.
 | Yellow Armor | Добавляет 50 брони.
 | Red Armor | Добавляет 100 брони.
Артефакты | Название | Описание
 | Fly | Дает возможность летать
 | Haste | Ускоряет скорость стрельбы и бега
 | Battle Suit | Принимаемые повреждение уменьшаются в два раза
 | Regeneration | Регенирирует 5 жизни в одну секунду
 | Quad Damage | Увеличивает наносимое повреждение в 3 раза
 | Invisibility | Невидимость (только по мультиплееру)
Награды | Название | Описание
 | Impressive | Дается за 3 подряд попадания из рэйлгана
 | Excellent | Дается, если в 2.5 секунды было сделано больше чем 1 фраг
 | Humiliation | Дается за убийство из gauntlet'a

NFKamp - MP3 Player

 Tribes AMP - Это mp3 проигрыватель, встроенный в Tribes. Для проигрывания mp3 музыки вам сначала надо создать плейлист. Плейлист это файл basenfk\music\mp3list.dat. В котором указанны полные пути к mp3 файлам. Для удобного создания плей листа есть программа "playlist generator for NFKamp", находится она в basenfk\music\NFKamp.exe
Управляется Tribes amp следующими командами:
mp3play - NFKamp: начать проигрывать mp3 из плей листа.
mp3next - NFKamp: следующий трэк к плэйлисте.
mp3stop - NFKamp: стоп.
mp3reset - NFKamp: стоп + перезагрузка плейлиста.
mp3volume - NFKamp: громкость музыки.

TROUBLESHOOTING

 Если у вас появляются подозрительные глюки то удалите файл nfkconfig.cfg в каталоге basenfk и запустите игру.
Встречающиеся проблемы:
- Если у вас ничего не пишется на консоли - переключитесь на английский шрифт.
- иногда Tribes не возвращается из альт+таба. Попробуйте подольше, покликайте на таскбар.

Если Tribes не запускается:
- Возможно у вас pentium<=200.
- Игра требует минимум DirectX8.1.
- У вас не поддерживается режим Direct3d8.
- Отсутствуют некоторые файлы из оригинальной поставки.

Если Tribes запустился, но не стартует карту.
- Карта, которую пытаетесь загрузить, является картой старого формата. Ее надо конвертировать через Tribesradiant.
- Отсутствуют некоторые файлы из оригинальной поставки.

Чтобы увеличить FPS попробуйте запустить Tribes в 16-битном режиме.

COMMAND LINE PARAMETERS

 Параметры командной строки вводятся следующим образом: "Tribes.exe +parameter1" или "Tribes.exe +parameter1 +parameter2 parameter3".

Параметры:
+gowindow | Оконный режим.
+nosound | Отключение звука.
+16bit | 16-ти битный режим видео.
+nfkplanet | Подсоединиться к nfk planet
+map | Загрузить карту
+game | Подключить геймдиректорию (gamedir)
+dll | Подгружать указанную dll (+dll mybot.dll)
+connect | Присоединиться к игре (+connect x.x.x.x)
+exec | Загрузить конфиг (+exec cfgname)
+dontsavecfg | После выхода из Tribes сохранятся Tribesconfig не будет.
+demo | Запустить демку (+demo demoname)
+nonet | Отключить определение сетевых настроек (включить тогда когда Tribes _долго_ загружается)
+nogamma | Отключить гамма контроль.

Пример: "Tribes.exe +gowindow +nosound".

Tribes поддерживает гейм директории, ваши файлы можно сложить в папку mydir. запускаем "Tribes.exe +game mydir" и Tribes будет работать с вашей директорирей параллельно с basenfk. В гейм дирах поддерживаются все файлы, кроме моделей.

Help file regenerated by Enforcer.
Design and Bugs by Spike.


------------------------
      Need For Kill
      by  3d[Power]
     version history
 http://www.3dpower.org
------------------------

ver 0.75
- Added: plasma jump! Now you can climb walls with plasmagun. Dont kill your self :)
- Added: Speed Jumping: during series of jumps player gain horizontal speed but loose jump height.
- Added: ability to change Video resolution. Command "r_mode" (1-3), or use setup.exe. Please note: network video resolution is forced to 640x480 due to gameplay balance. New hotseat map sizes available: 640х480 - 20х30; 800x600 - 25x37; 1024x768 - 32x48; (bricks).
- Added: new visual effect: plasma explosion.
- Added: new visual effect: small smoke from shotgun while firing. ( command "r_fx_shotgun")
- Added: marks. which stay at walls after gunshots. (command "r_markstime")
- Added: free fly camera mode. available during demos or spectating. (for non hotseat maps)
- Added: ability to BAN players (command "banplayer"). Ban list reset if server shutdowns.
- Added: demos list scrolling with pgup, pgdn keys.
- Added: demos deleting by "ctrl+delete" hotkey, at DEMOS screen. (warning: no confirmation)
- Added: nfk supports backgrounds with big resolution (up to 1024x1024 and more :) depends on your video card. (note: backgrounds located at basenfk/custom)
- Added: two new maps pro-dm14 and tourney10. And tourney7 a litl bit modified.
- Added: command "drawtime" - do [not] show time.
- Added: command "ch_showfollowinglabel" - do [not] show label "following" at demos or spectator mode.
- Added: loading brick pallette from external file. command "loadbrickpallette mypal.bmp" or "loadbrickpallette mypal.bmp $FF00FF", where $FF00FF transparent color (hex).
- Changed: command "smoke" removed, use "r_fx_smoke" 0-2 instead.
- Fixed: "integer overflow" error
- Fixed: wrong spectating game with > 3 players.

ver 0.70a
- fixed: network code bugs fixed.

ver 0.70
- Added: new ultimate bloody MASSACRE mode :) you can enable it by console command "r_massacre 1" (1-5). Disabled by default.
- Changed: weapon Machinegun now animated while firing.
- Added: New animated powerups.
- Changed: many graphics was remixed. Antialiasing was added (smoothing).
- Added: short stats (frags etc) now displays at console after match end.
- Changed: player's crosshair aiming now more precise. It now react even to very little mouse movement. Players with optical mouses can easily notice that.
- Added: New ingame chat panel. binded to Enter key (by default  (bind enter messagemode)). (console command "messagemode", or "messagemode2" for team chatting).
- Added: Weapon gauntlet got a flashy spark :)
- Added: New player model, sarge. Fine animation and looks muuch better. (replaces older one).
- Added: Gamma control. Console command "gamma" (0-20).
- Added: New official map DM7. Best for ffa, tdm.
- Added: New command line parameters (for more info read help file).
- Added: command "r_fx_rail", switch between older rail and new rail.
- Added: command "sv_mapcycle" 1|0, toggles auto map changer .
- Changed: Nfk can play demos from gamedirs (nfk.exe +game mydir). Also you can use (demo c:\demo1.ndm) (nfk.exe +demo "c:\demo1.ndm");
- Added: demos now save players ping.
- Added: demos now save overtime info.
- Added: q3 style console commands autocompletion. (TAB key).
- Added: now you allow to bind functional keys F1 - F12.
- Added: ability to unbind selected key ("unbind ctrl").
- Added: if you choose a model, nfk prints short list of skins included into selected model.
- Added: console command  "modelslist", shows models list.
- Added: console command "cg_swapskins", changes teams colors (red-blue). Only visual effect. Your real team color is not changing.
- Added: console command "r_animatedmega"
- Added: nfk supports gamedirs. "nfk.exe +game mydir", mydir will works separately with basenfk folder.
- Added: nfkchat.exe was updated to version 1.0
- Added: bot sdk revision 6
- Fixed: command "enemymodel " no affects bot instantly, hotseat game.
- Changed: network code more optimized now.
- Added: support for german keyboards. (to toggle console use ^ key).
- Added: new help file, with new design.

ver 0.64
- Added: New Shaft and Railgun (new settings: r_railwidth, r_railstyle)
- Added: Gibbable coprses (by Explosions).
- Added: option "Zoomed (for LCD)" to Setup.exe, which is dedicated for LCD monitors. cuz 640x480 fullscreen is not best resolution for LCD.
- Added: New HUD. Auto enabling at wide maps. This HUD is no supposed to use for hotseat mode. New commands: ch_hudWidth, ch_hudHeight, ch_hudX, ch_hudY, ch_hudAlpha, ch_hudIcons, ch_hudshadow, ch_hudStretch, ch_hudVisible
- Added: black tag for nick names ^0
- Added: ability to paste text from clipboard into console (ctrl+v). you also can paste ip adress into direct join edit field.
- Added: automatical map changer. File basenfk\maplist.txt contain map names. Server automatically grab map names from there after match ending.
- Added: command "h_exec", same as "exec" but dont show "execing *.cfg" text.
- Added: 'rcon' server control (from client). Command "rconpassword" set ups password for future rcon use. Example client command: "rcon restart".
- Added: nfk server now allow port changing (sv_port 29998). to connect to such server, use : "connect 192.168.0.1:29998". sv_port changing is not available if using nfk planet, or lan servers searhing.
- Changed: Corpses now fade, instead of just dissapearing.
- Changed: now now loads only nessesary models. (faster loading)
- Changed: network code has been rewrited. Works much better now.
- Changed: Fragbar panel, now displaying also in hotseat mode, if match bettween player and bots.
- Added: if 'callvote' active, bots vote same as server vote.
- Added: warmup timer now waiting until map has at least two players.
- Added: command "r_animatedarmors"
- Changed: now you allowed to change client map bricks pallete. Server will not detect this map as "different".
- Changed: command "shownick 2" shows nick only at enemies.
- Fixed: corpses fell thru bricks (?)
- Fixed: dedicated server display frags in wrong way.
- Fixed: nfk crashes if player count was more than 5.
- Fixed: unpickupable items (multiplayer game).
- Fixed: long nickname with "ch_qwscoreboard" enabled, crashes game.
- Fixed: symbol "|" inside nickname craches autorecord command.

ver 0.60
- Added: servers searching on lan (LAN Broadcast).
- Added: spectators. Command "spectator 1" entered in main menu, and then connect to server, will join you as spectator.
- Added: command "sv_allowspectator", Allows spectators on this server.
- Added: command "sv_maxspectators". Max spectator count.
- Added: command "sv_powerup", (dis)allow powerups on this server.
- Added: New scoreboard, in QuakeWorld style, enable by command "ch_qwscoreboard 1"
- Fixed: nfk hangup with playing some demos.
- Changed: bots now automatically select their team, if team was not assigned by player.
- Added: new network code optimizaion, automatically enables if players count > 2.
- Added: new meat! (gibs)
- Fixed: after match end, players still firing from shaft weapon.
- Fixed: sometimes multiple flags can appear in internet game.
- Added: TGA 32 bit support for models. (old bmp format still supported).
- Changed: maximum frame size in model, now 96, for avoiding cheating.
- Fixed: last char in team_say chat dissapears sometimes.
- Fixed: plasma bullets fly thru players in demos.
- Fixed: error "map not found" appears sometimes in multiplayer games, even if map exists.
- Added: droppable powerups (quad, regen, etc).
- Fixed: general connection problems in multiplayer was solved. Now you can host games even if you are behind gate (dont have a public IP).
- Fixed: invisible bot was visible :)
- Fixed: dedicated teamplay server ask for team selection.

ver 0.57
- fixed: troubles with connection to internet host. Now you can connect via gateway (public IP), or via GPRS.
- fixed: deleting bot with flag causes flag removal.
- fixed: console command "enemymodel" doesn't work with bots.
- changed: message "dropped by timeout" now displayed if player, guess what?
- added: now if players cound limited by command "sv_maxplayers", you will receive message about that.
- added: Option "Restart Level" in ESC menu, replaced with "Restart Demo" in demos.
- added: ability to use space char in player's name and in sv_hostname

ver 0.56
- Added: bot.dll support
- Added: new maps: DM0 and CTF2.
- Added: automatic demos mp3 comment loading. For example, if you watching \demos\demo1.ndm, then \music\demo1.mp3 will be played.
- Added: scoreboard sorting (by frags).
- Improved: HOTSEAT menu now more functional, every option now selectable & activatable by mouse.
- Changed: new lava\water animation.
- Added: grenades new look. Toggles by option "r_altgrenades 1"
- Added: command "reconnect", reconnects you to last known server.
- Added: map preview now scrolls, if map is too big.
- Added: option "disable player 2: yes\no" in HOTSEAT menu, for playing with bots.
- Added: now you can select team, in team games, from ESCcape menu.
- Impoved: more flexible console edit, you can use keys leftarrow, rightarrow, home, end, delete.
- nfkchat: new nfkchat.exe version v0.71 is included.
- nfkchat: new design & easy functionality. also supports private talks.
- Changed: command "kickplayer" automatically prints all <playerid>
- Changed: players stops their movement at game end. (they run in to a wall in past)
- Changed: wrong IP Address now do not goes into Direct Join ip's history.
- Changed: console history now doesn't remember double typed commands.
- Changed: binds num- num+ num* now work.
- improved: command "randommodels" now more intelligent.
- improved: now you can record and play demos with space (" ") chars in filename.
- fixed: bugs in "callvote".
- fixed: client player can't respawn sometimes.
- fixed: timelimit affects on Trix Arena gametype.
- fixed: if server records a demo, and client change the name, demo wont record it.
- fixed: exec cfg from same cfg -> result: deadlock.
- fixed: autorecord fails to save demo if player(s) name contain chars < >
- fixed: bug with statusbars in client's 1v1 demos.
- fixed: nfk hang up sometimes, when playing demo.
- fixed: cheat with "cameratype 0" at big maps.
- fixed: ability to join clients !
- fixed: maps "read only" file attr hang up nfk.
- fixed: command "mp3play" located in autoexec.cfg does not work.
- fixed: changing map background before recording demo, affects on background in demo.
- fixed: server's players with command "sv_testplayer2 1" are invisible at clients.
- fixed: failed to load graph.d at WINNT, because of OS restrictions.
- fixed: ability to start new vote, before end of previous.
- fixed: chat with lenght 1 is not sending.
- added: english help file for NFK Radiant, "map_ed\radiant_help_eng.txt".

ver 0.50
- New, greatly improoved and optimized network code. Protocol also changed. Nfk uses UDP now.. (port 29991).
- Online NFK Master Server was added, which named "NFK PLANET". It is a place where nfk players can play with each other.
- Added: if nfk server is in fullscreen mode, and minimized, then somebody connects, nfk popup it self.
- Added: command "sv_maxplayers", for limiting maximum amount of players.
- Added: command "ipinvite". invites specified ip address to your server. Useful then connection is available only to one direction
- Added: command "net_showbandwidth". shows channel current bandwidth, bytes/sec (network).
- Added: command "minimize". minimizes nfk window
- Added: VOTING. You can toggle voting for some console command, and if number of positive (YES) votes will be enough to apply this command, it will be executed at server.
    You can vote for: restart, ready, map, fraglimit, timelimit, capturelimit, domlimit, warmup,warmuparmor, forcerespawn, sync, sv_teamdamage, net_predict, sv_maxplayers.
    Example: "callvote restart", "callvote map tourney4".
    Server's voting console commands: sv_allowvote, sv_vote_percent, sv_allowvote_restart, sv_allowvote_fraglimit, sv_allowvote_timelimit, sv_allowvote_capturelimit, sv_allowvote_domlimit, sv_allowvote_ready,
    sv_allowvote_map, sv_allowvote_warmup, sv_allowvote_warmuparmor, sv_allowvote_forcerespawn, sv_allowvote_sync, sv_allowvote_sv_teamdamage, sv_allowvote_net_predict, sv_allowvote_sv_maxplayers.
- Added: nfk remembers frags count of dropped players, and restores it upon players reconnect.
- Fixed: several bugs in DEMOS screen.
- Changed: command "ipaddress" now improoved, now it show internal and external ip address.
- Added: nfk guesses player's position based on player's ping. Recommended to be enabled, expecially at dedicated servers. (command "net_predict 1");
- Improoved: shaft was greatly improoved, it not laggy now :)
- Improoved: stability and efficiency of server, and dedicated server. Now it works more effectively then players count is more than 2.
- Added: dedicated server chat ability
- Fixed: sometimes multiplayer's demos, not work.
- Fixed: sometimes clients cannot join, because of modified map (but maps was equial)
- Fixed: bugs with midi music player.
- Changed: long map names now stripped by mapnames viewer.
- Fixed: bug in map editor with deleting objects


------------------------
      Need For Kill
      by  3d[Power]
     version history
 http://www.3dpower.org
------------------------

ver 0.75
- добавлено: plasma jump! Теперь плазмой можно карабкаться по стенам ) Не убейтесь.
- добавлено: Speed Jumping: распрыг. если бежать в одну сторону прыгая, то постепенно скорость бега нарастает.
- добавлено: смена видео разрешений. Команда r_mode (1-3). Примечание: по мультиплееру разрешение ограничено до 640х480, ввиду игрового баланса на больших картах. По поводу размеров карт, Можно создавать новые хотсит карты которые умещаются в экран: 640х480 - 20х30; 800x600 - 25x37; 1024x768 - 32x48; (в бриках).
- добавлено: визуальный эффект разрыва плазмы при столкновении.
- добавлено: визуальный эффект небольшого дыма при выстреле из shotgun ( команда "r_fx_shotgun" ).
- добавлено: marks. Отпечатки от выстрелов на стенах. (r_markstime)
- добавлено: режим свободного полета камеры (free fly) для демок, и спектаторов. (на больших картах)
- добавлено: возможность бана игроков. (banplayer). Бан лист сбрасывается при закрытии сервера.
- добавлено: в окне DEMOS скроллирование кнопками pgup, pgdn
- добавлено: удаление демок прямо из NFK, ctrl+del в окне DEMOS. (warning: без подтверждения)
- добавлено: нфк теперь поддерживает бэкграунды любых разрешений.
- добавлено: две новых карты pro-dm14 и tourney10. Также слегка изменена tourney7.
- добавлено: конс команда "drawtime" - [не]показывает время.
- добавлено: конс команда "ch_showfollowinglabel" - [не]показывает надпись "following" в режиме спектатора (демках).
- добавлено: загрузка палитры из внешнего файла "loadbrickpallette mypal.bmp" или "loadbrickpallette mypal.bmp $FF00FF", где $FF00FF шестнадцатеричный цвет прозрачности.
- изменено: нфк теперь по другому записывает демки, адаптируясь к сетевой синхронизации игроков, создавая такую-же синхронизацию в демках. Что снижает "дерганность" некоторых игроков при последующем просмотре демки. (и теперь размер демки зависит от sync).
- исправлено: если начать стрелять из шафта и открыть консоль, то стрельба продолжалась, и патроны не расходовались.
- изменено: убрана команда "smoke", теперь дым переключается командой r_fx_smoke 0-2
- исправлено: на клиенте не записывались в демку клиентские выстрелы из шотгана.
- исправлено: при игре на много человек появлялась ошибка integer overflow. На локалке правда остались кое какие глюки которые непонятным образом проявляются :( но ...
- исправлено: при игре на много человек неправильно работали спектаторы.

ver 0.70a
- исправлен баг при игре на много человек.

ver 0.70
- Добавлено: Кровавый режим MASSACRE! стекающая кровь по стенам. :) по умолчанию выключена, включается командой "r_massacre 1", (макс значение 5)
- Изменено: оружие Machinegun. Теперь ствол этого оружия вращается при выстреле.
- Добавлено: новые анимированные поверапы.
- Изменено: переделано много графики, добавлен Антиалиас (сглаженность). Такие изменения коснулись: флагов, оружия, и прочих мелких спрайтов.
- Добавлено: после окончания партии на консоль выводится краткая информация о игре (название карты, настройки, кол-во фрагов игроков, дата и время окончания).
- Изменено: Прицел игрока теперь реагирует сверх точно на движения мыши. Раньше слишком маленькие движения пропускались. Вобщем, теперь возможно более точное прицеливание.
- Добавлено: чатиться теперь можно через специальную всплывающую строку (вызывается по Enter (или консольной командой "messagemode")). (для team чата, команда "messagemode2"). Только по мультиплееру.
- Добавлено: искра от gauntlet теперь светится :)
- Добавлена: Новая мега модель Sarge, в ней куча фреймов анимации и выглядит лучше. Заменяет старую.
- Добавлен: регулятор гаммы. Конс команда "gamma". от 0-20.
- Добавлено: новая офиц карта DM7.
- Добавлено: Добавлено много новых параметров командной строки. см подробнее в Command Line Parameters в хелпе.
- Добавлено: команда "r_fx_rail", переключает между новым и старым внешним видом луча рейлгана.
- Добавлено: команда "sv_mapcycle" 1|0, отключает автосмену карт на сервере.
- Исправлено: теперь команда enemymodel на ботов в хотсите применяется сразу же, перезагрузка карты не требуется.
- Изменено: нфк теперь умеет проигрывать демки из gamedir, если таковая указана. Также работают абсолютные пути (demo c:\demo1.ndm) (также работает nfk.exe +demo "c:\demo1.ndm");
- Добавлено: в демку теперь сохраняется пинг игроков.
- Добавлено: в демку теперь сохраняется Overtime (если таковой был).
- Добавлено: теперь нормальное автодописывание команд на консоли. (по кнопке TAB).
- Добавлено: добавлена возможность назначения (bind) на функциональные клавиши F1 - F12.
- Добавлено: возможность анбинда (unbind) выбранной кнопки. пример: "unbind ctrl". Снимает назначенное кнопке значение.
- Добавлено: теперь при выборе модели на консоли пишут список невыбранных скинов из этой модели )
- Добавлено: конс команда "modelslist", выводит на консоль список загруженных моделей.
- Добавлено: конс команда "cg_swapskins", меняет цвета моделек в командной игре (red<->blue). Только визуально, физически команды остаются прежними.
- Исправлено: иногда по мультиплееру режим разыгровки оставался даже после начала партии (на клиенте).
- Исправлено: иногда по мультиплееру на игрока создавалось несколько моделек ;) (на клиенте)
- Добавлено: Нфк теперь поддерживает гейм директории, ваши файлы можно сложить в папку mydir. запускаем "nfk.exe +game mydir" и NFK будет работать с вашей директорирей параллельно с basenfk. В гейм дирах поддерживаются все файлы, кроме моделей.
- Добавлено: команда "r_animatedmega"
- Добавлено: Обновленный нфк чат, до версии v1.0
- Добавлено: bot sdk revision 6
- Изменено: улучшен и оптимизирован сетевой код.
- Добавлена: поддержка немецких клавиатур (не работала консоль).
- Изменено: теперь двум клиентам возможно играть на сервере, даже когда у них одинаковый IP адрес.
- Добавлено: новый help файл. с новым дизайном.

ver 0.64
- Добавлено: новый шафт и рейлган (настройки рейла: r_railwidth, r_railstyle)
- Изменено: Переделан сетевой код. Теперь не тормозит при 5ти и более игроках в лан игре. Также улучшена игра по интернету.
- Добавлено: Трупы теперь разрываются на мясо от взрывов ракет и гранат.
- Изменено: Трупы теперь тают, а не просто исчезают.
- Изменено: нфк теперь подгружает модельки только по мере необходимости (более быстрая работа нфк при большом колве моделей)
- Добавлено: Вставка текста из буфера обмена в консоль (ctrl+v). Также возможна вставка IP адреса из буфера в поле ввода окна Direct Join.
- Исправлено: трупы проваливались сквозь кирпичи(?)
- Исправлено: неправильно показывались фраги у dedicated сервера. также исправлено что нажатием mouse1 не менялся pov (то за кем следить камерой).
- Исправлено: при "ch_qwscoreboard 1" слишком длинное имя игрока вызывало ошибку.
- Добавлено: команда "h_exec". работает также как и "exec", только не выводит на консоль надпись "execing *.cfg".
- Исправлено: если в имени игрока был символ "|" команда autorecord не работала.
- Добавлено: черный цвет в имени игрока. тэг ^0
- Добавлено: новый HUD. На больших картах включается по умолчанию. HUD предназначен только для игрока 1. Команды настройки: ch_hudWidth, ch_hudHeight, ch_hudX, ch_hudY, ch_hudAlpha, ch_hudIcons, ch_hudshadow, ch_hudStretch, ch_hudVisible
- Изменено: панелька с фрагами (fragbar), теперь появляется и в Hotseat, если идет игра одного человека с ботами.
- Добавлено: Боты, при активном callvote, голосуют также как проголосовал сервер.
- Добавлено: rcon управление сервером с клиента. Команда "rconpassword" устанавливает пароль на "rcon" управление. Ввод команд серверу - через команду "rcon". Например "rcon restart". Консоль синхронизированна очень хорошо, создается ощущение что на клиенте серверная консоль :)
- Добавлено: у нфк сервера теперь можно сменить порт (sv_port 29998), подсоединяться к таким серверам так "connect 192.168.0.1:29998". Примечание: к серверу с нестандартным портом нельзя присоединиться через nfk planet, или через lan server searching.
- Добавлено: warmup таймер не отсчитывается если на карте меньше 2х игроков.
- Добавлено: в программе Setup.exe, появилась опция "Zoomed (for LCD)" которая предназначена для ЖК мониторов.. поскольку на них 640х480 не всегда хорошо смотрится.
- Добавлено: команда "r_animatedarmors"
- Добавлено: Автоматический менятель карт :) в файле basenfk\maplist.txt указаны названия карт. Сервер по окончанию партии (+15сек), по рандому выбирает из списка карту.
- Добавлено: в сетевой код добавлена система antipacketlost, поможет воостанавливать дропнутые пакеты (типа играть лучше станет, вроде как :)
- Изменено: нфк теперь подругому проверяет отличается ли карта клиента от карты сервера, анализируя структуру карты. (раньше слепо сравнивала файлы).
- Изменено: команда "shownick 2" включает отображения ника только над противниками
- Исправлено: нфк сервер закрывался с ошибкой при игре >= 6 чел.
- Исправлено: иногда, при подсоединении к серверу, не все игроки были видны.
- Исправлено: иногда по мультиплееру не подбирались предметы (на клиенте)

ver 0.60
- Добавлено: Поиск серверов по лану (LAN Broadcast), в меню MULTIPLAYER появился соответствующий пункт.
- Добавлено: Спектаторы. команда "spectator 1" теперь снова работает. Набрав ее на клиенте, можно присоединиться к серверу в качестве наблюдателя.
- Добавлено: команда "sv_allowspectator". Разрешает \ запрещает на сервере присоединение спектов.
- Добавлено: команда "sv_maxspectators". Максимальное колво спектов которые могу присоединиться к этому серверу.
- Добавлено: команда "sv_powerup". Разрешает \ запрещает на сервере powerups (появление предметов quad, haste итп).
- Добавлено: новая scoreboard. В стиле QuakeWorld, включается командой "ch_qwscoreboard 1"
- Исправлено: нфк подвисало после окончания проигрывания некоторых демок.
- Изменено: теперь боты в командных режимах игры сами выбирают себе команду, если она не была назначена игроком.
- Добавлено: оптимизация сетевого кода, если игроков > 2. Должно уменьшить кол-во траффика, и уменьшить лаги.
- Добавлено: новый внешний вид мяса.
- Исправлено: после окончания партии игрок продолжал стрелять из шафта, накручивалась статистика выстрелов.
- Исправлено: на клиенте в инет игре, могло появиться несколько CTF флагов.
- Добавлено: поддержка TGA 32 bit формата в моделях. Модели в bmp по прежнему работают. Но в случае если вместо bmp указаны TGA, модель грузится в 32 bit с альфа каналом.
- Исправлено: максимальный размер фрейма в модели теперь 96, во избежании читов с командой "enemymodel".
- Исправлено: пропадала последняя буква чата say_team, при сетевой игре на несколько человек.
- Исправлено: плазма пролетала сквозь игроков в демках.
- Исправлено: клиенту иногда писали "map not found", когда карта есть. Такое случалось если путь к nfk.exe был слишком длинный.
- Добавлено: выпадающие после смерти поверапы (квад, итп).
- Исправлено: решена основная проблема не коннекта в интернет играх, теперь можно присоединяться к сервакам до которых нету пинга, иными словами можно создавать игры будучи за шлюзом, который с блокированием входящего траффика.
- Исправлено: бота с невидимостью было видно.
- Исправлено: dedicated teamplay server просил выбрать команду.

ver 0.57
- Исправлено: проблемы с коннектами по интернету. Теперь можно коннектится из-за шлюза, или через GPRS.
- Изменено: теперь при дропе таймаутных игроков, пишут "dropped by timeout".
- Исправлено: если удалить бота с флагом - флаг пропадал навсегда.
- Исправлено: команда "enemymodel" не работала на ботов.
- Добавлено: если кол-во игроков лимитированно командой sv_maxplayers, то при добавление бота, об этом пишут.
- Добавлено: теперь в меню по кнопке ESC, в демке, вместо Restart Level, опция Restart Demo - проигрывает демку заново.
- Добавлено: в имени (name) и sv_hostname теперь можно использовать пробелы.

ver 0.56
- Добавлено: поддержка bot.dll
- Добавлены: две новых карты: DM0 и CTF2.
- Добавлено: автоматический проигрыватель комментариев к демке. Если допустим вы проигрываете \demos\demo1.ndm, то сразу будет проигрываться \music\demo1.mp3
- Добавлено: игроки теперь сортируются в SCOREBOARD в зависимости от кол-ва фрагов.
- Добавлено: команда "reconnect". Пере подсоединяет к последнему серверу.
- Добавлено: превью карты в меню теперь скроллируется если карта большая.
- Изменено: доработано меню HOTSEAT, player1\2 properties. Теперь все пункты выбираются мышью, при наведении. И активируются при нажатии mouse1.
- Изменено: теперь новая анимация лавы\воды.
- Добавлено: новый внешний вид гранаты (опционально). Включается командой "r_altgrenades 1". thnx to [MWMD]-Spike.
- Добавлено: опция "disable player 2: yes\no" в окне HOTSEAT. Для игры с ботами.
- Добавлено: команду (team) теперь можно выбирать из InGameMenu (то которое по ESC). (В вармапе).
- Добавлено: улучшенное редактирование строки ввода в консоли. Можно использовать стрелки leftarrow, rightarrow для позиционирования курсора. Работает del.
- nfkchat: с 056 поставляется новый NFKChat v0.71.
- nfkchat: изменён дизайн программы (в лучшую сторону). Более простой и понятный интерфейс. Убраны некоторые глюки, а также добавлена возможность приватного разговора.
- Изменено: теперь при вводе команды "kickplayer" сразу показываются все <playersid>.
- Изменено: по окончанию партии, игроки останавливают свое движение (раньше бежали в стену).
- Изменено: теперь неправильно введенный ip address, в окне Direct Join, не добавляется в хистори .
- Изменено: хистори введенных комманд на консоли, теперь не запоминает повторно введенные команды.
- Изменено: восстановлена работа биндов num- num+ num*
- Улучшено: команда "randommodels" теперь ведёт себя более разумно.
- Улучшено: теперь можно проигрывать и записывать демки содержащие пробелы в названии файла (" ").
- Исправлено: глюки в callvote.
- Исправлено: иногда чел на клиенте не мог респавниться.
- Исправлено: в режиме игры Trick Arena работал timelimit.
- Исправлено: если на сервере записывалась демка, а клиент сменил имя, то в демке это не отображалось.
- Исправлено: раньше можно было из конфига ехеc'нуть сам конфиг. результат: dead loop.
- Исправлено: если прописать quit или halfquit в autoexec.cfg, то нфк умирал.
- Исправлено: если в имени игрока были символы < > то демка не записывалась. (autorecord)
- Исправлено: глюк со статус барами в клиентских дуэльных демках.
- Исправлено: некоторые демки подвисали при проигрывании.
- Исправлено: раньше можно было читить на больших картах с помощью команды cameratype 0
- Исправлено: можно было присоединяться к клиентам.
- Исправлено: атрибут "read only" на нфк картах, вешал нфк.
- Исправлено: команда "mp3play" написанная в autoexec.cfg теперь работает.
- Исправлено: раньше если после загрузки карты сменить BG, то в демку запишется выбранный BG, а не тот который был в карте.
- Исправлено: при использовании команды sv_testplayer2 1, клиенты не видели серверного игрока2.
- Исправлено: возможно исправлено, то что не загружался файл graph.d под WINNT. из-за действующих ограничений системы.
- Исправлено: раньше можно было выдвигать новое голосование (vote), пока еще не закончилось старое.
- Исправлено: нельзя было послать чат из одной буквы.

ver 0.50
- Новый, и сильно улучшенный и оптимизированный сетевой код. Также изменился протокол. Сетевая игра теперь по протоколу UDP (порт 29991).
- Добавлен NFK Master Server, который называется NFK PLANET. Это сервер в инете, где Вы можете увидеть список серверов, и\или занести туда свой.
- Добавлено: Если нфксерв в фуллскрине, и альттабнут, то когда ктонибудь коннектится, нфк сама возвращается из альттаба.
- Добавлено: команда "sv_maxplayers" . Лимит игроков на сервере.
- Добавлена команда "ipinvite". Кидает приглашение в игру по указанному IP адресу. Полезно если соединение устанавливается только в одну сторону.
- Добавлена команда "net_showbandwidth". Показывает прокачку. bytes \ sec.
- Добавлена команда "minimize" - cворачивает нфк, (полезно когда alt+tab не помогает).
- Добавлено: голосование (callvote). Можно выдвигать на голование выбранную консольную команду, по проценту проголосовавших ЗА, выбирается, будет ли применена команда.
    Конс команды: sv_allowvote, sv_vote_percent, sv_allowvote_restart, sv_allowvote_fraglimit, sv_allowvote_timelimit, sv_allowvote_capturelimit, sv_allowvote_domlimit, sv_allowvote_ready,
    sv_allowvote_map, sv_allowvote_warmup, sv_allowvote_warmuparmor, sv_allowvote_forcerespawn, sv_allowvote_sync, sv_allowvote_sv_teamdamage, sv_allowvote_net_predict, sv_allowvote_sv_maxplayers.
    Возможно голосовать за команды: restart, ready, map, fraglimit, timelimit, capturelimit, domlimit, warmup,warmuparmor, forcerespawn, sync, sv_teamdamage, net_predict, sv_maxplayers.
    Пример: "callvote restart", "callvote map tourney4"
    Отключение команд sv_allowvote_XXX запрещают отключенный вид голосования. sv_allowvote 0 - запрещает голосование в целом. +Добавлен звук, который проигрывается при старте голосования.
- Добавлено: нфк запоминает кол-во фрагов дропнутых игроков, если они вновь подсоединились, им восстанавливают их фраги.
- Исправлено: убраны разные глюки с демками, и глюки в окне DEMOS.
- Изменено: улучшена конс команда "ipaddress", она теперь показывает внутренний и внешний IP.
- Добавлено: новая система предугадывания позиции игроков, что дает более точную подгонку позиций игроков на больших пингах (net_predict 1)
- Улучшено: полностью переделан шафт, теперь им возможно стрелять в инет игре (не лагает).
- Улучшено: улучшена работа сервера, и decicated сервера, теперь если играет большее колво игроков, и у сервера быстрый коннект, то от этого лучше всем, раньше это не имело значения практически.
- Улучшено: возмножность чата dedicated сервера.
- Исправлено: иногда демки записанные по мультиплееру, не работали.. вылетали с ошибкой.
- Исправлено: иногда на сервер не пускали, говорили что карта отличается (хотя они одинаковые).
- Исправлено: иногда неправильно загружалась карта при серфинге по каталогам в списке карт.
- Исправлено: глюки с midi проигрывателем.
- Исправлено: окончательно прибиты все глюки функциональности окна DEMOS.
- Изменено: теперь слишком длинные имена демок и карт, обрезаются при отображении.
- Исправлено: баг в редакторе карт с удалением спец объектов.

ver 0.40
- Изменено: полностью переделан вывод звука, теперь он не будет пропадать на компах на которых это происходило. Это касается и отставания mp3 в nfkamp.
- Изменено: в NFK теперь новый shotgun (выглядит по другому). Прошу любить и жаловать :).
- Добавлено: в демках и в режиме спектатора, POV (за кого смотреть) можно менять кнопкой fire (по умолчанию mouse1).
- Добавлено: команда cl_avidemo. Во включенном режиме, последовательно сохраняет скриншоты в basenfk\. Поле чего эти скриншоты можно склеить в avi файл (например в adobe premier).
- Добавлен: коментатор текущего счета :), говорит "youre lost the lead" или "teams for tied". консольная команда "announcer"[0-1].
- Добавлено: команда sv_testplayer2. Сервак создается с 2мя игроками (второй - на клаве). Терь на 2х компах можно поиграть в троем.
- Исправлено: глюки с вертикальной синхронизацией. Терь в полноэкранном режиме экран не будет "моргать". Возможность включения \ выключения вертикальной синхронизации у монитора.
- Добавлено: Теперь в NFK можно добавить свои брики. Делается это через "configure\brick palette" в NFKRadiant.
- Изменено: консоль теперь "выкатывается" а не просто появляется.
- Добавлено: возможность замены всех 8ми бэкграундов нфк. а также замена заднего фона консоли, и подложки под окно статистики.
- Добавлено: в каталоге maps можно создавать поддиректории. Они адекватно воспринимаются самим nfk.
- Добавлено: возможность использования скроллера. (можно биндить: mwheelup, mwheeldown).
- Добавлено: после смерти из игроков вываливается оружие. Этого не происходит в режимах игры TRIX, PRACTICE, RAILARENA. Выпавшее оружие лежит минуту, потом исчезает.
- Добавлено: Эффект света, применено на: ракеты, взрывы, плазму. А также чел с квадом теперь светится. Все это отключается командой "r_040fx 0".
- Изменено: дым от ракет и гранат теперь намного красивее.
- Добавлено: возможность командного чата. Команда "say_team RA Taken".
- Добавлено: возможность биндить ЛЮБУЮ команду. Например: bind space say just a business, nothing personal. (кавычки при этом использовать нельзя).
- Добавлено: новый сетевой режим игры CAPTURE THE FLAG. Захват флага.
- Добавлено: новый сетевой режим игры DOMINATION. Доминирование.
- Добавлено: Добавлен setup.exe. Это программа настройки некоторых параметров NFK.
- Добавлено: Возможность выбора hardware \ software звука.
- Исправлено: глобальное торможение NFK под некоторыми системами (например на некоторых Windows XP)
- Добавлено: teambar (Только в командных режимах игры). панель, отображающая статус игроков в вашей команде, показывает: ник, жизни, армор, оружие, локацию.
- Добавлено: настройки teambar. "ch_teambar_color"[0-13] - цвет панели. "ch_teambar_style"[0-3] - стиль панели. "ch_teambar_showmyself"[0-1] - не показывать себя в панели..
- Изменено: Значительно улучшена консольная команда "map": (1,2).
1) В нее встроен автоматический поиск, к примеру если вашу карту нфк не нашел в корневой папке maps, то он проводит сканирование всех вложенных подпапок в maps, и в итоге найдет вашу карту гдебы она не лежала :). Теперь достаточно писать просто "map mapname", без указывания поддиректорий.
2) Команда map теперь может менять GAMETYPE! (тип игры). Как сменить gametype: Команда "map dm2 deathmatch" загрузит карту dm2 в режиме DeathMatch. Чтобы получить help по смене gametype'ов (и все значения параметра gametype), введите (в нфк) "map dm2 help".
- Добавлено: команды "nextwpn_skipempty", "p2nextwpn_skipempty", если включено, то при выборе оружия, через nextweapon и prevweapon, не будут выбираться оружия без патронов.
- Добавлено: команда writeconfig. "writeconfig myconfig", в файл myconfig.cfg будут записаны текущие настройки нфк.
- Исправлено: иногда скорость анимации модели после конца haste оставалась такойже быстрой как и при наличии haste.
- Добавлено: теперь если соединение сильно лагает, то появляется надпись "Connection Interrupted".
- Исправлено: area_waterillusion пропадал раньше времени при скроллинге на больших картах.
- Исправлено: иногда анимация лавы\воды сбивалась на больших картах
- Исправлено: в ffa демках fragbar показывал значение -9999.
- Исправлено: при выходе из нфк не запоминался параметр mouselook.
- Исправлено: брики, замененные командой brickreplace, сохранялись в демку.
- Исправлено: если в названии демы был знак "?", то при записи демы на винт, нфк умирал напрочь :)
- Изменено: команда autorecord. раньше имя игрока вставлялось в имя файла вместе с тэгами (^1^b), теперь тэги вырезаются.
- Исправлено: переписаны алгоритмы воспроизведения hit.wav. Раньше почему-то он проигрывался у того кого поранили, теперь он проигрывается у того чела который поранил.
- Исправлено: регуляторы громкости volume, mp3volume теперь корректно работают. и полностью не зависят друг от друга.
- Добавлено: NFKRadiant: операция CUT selecion (копирование+удаление (вырезание)).
- Исправлено: NFKRadiant: глюк: около doortrigger отрисовывался кусочек воды.
- Добавлено: теперь при повторном заходе в окно DEMOS, выбирается ранее выбранная дема. (запоминается типа).
- Добавлено: команда "r_displayrefresh". Изменяет частоту монитора в полноэкранном режиме. (пока особо не тестировалась).
- Добавлено: по окончанию демки у всех игроков выключается включенный gauntlet...
- Исправлено: теперь когда вы пытаетесь поиграть на карте где нет респавнов, вы не увидите нечеловеческих глюков, вас просто выкинут в меню, и скажут "кривая карта".
- Добавлено: команда "r_bgmotion". Бэкграунд движется не синхронно с картой (пространственный эффект). (только на больших картах).
- Добавлено: возвращена команда заливки цветом заднего фона. "fill_bgr", blue green red. (работает только с "drawbackground 0")
- Добавлено: команды настройки консоли: "ch_conspeed" "ch_conheight" "ch_conalpha". (скорость консоли, высота консоли, прозрачность).
- Изменено: команда "shownick 1" теперь применяется сразу, независимо то autoshownick.
- Исправлено: отклонение положения имени, наград от трупов в демке.
- Добавлено: NFKRadiant: кнопка F5 перемещает текуще-выбранный объект (или локацию) в положение курсора.
- Исправлено: теперь команда "enemymodel" работает правильно (не сбрасывается)
- Добавлено: консольная команда "teammodel", назначает вашим тиммэйтерам выбранную модель.
- Добавлено: конс команда "r_railstyle". Стиль луча рэилгана. [0 - 4] (5 видов). (thnx to Deadlock)
- Изменено: немного оптимизирован сетевой код, теперь должно меньше лагать на медленных коннектах.
- Добавлено: конс команда "clear". Очищает консоль.
- Изменено: теперь после подбирания оружия, которого у вас не было, зажигается weaponbar.
- Добавлено: конс команда "cmdlist" - выводит список всех возможных конс комманд.
- Исправлено: на клиентах игроки после смерти не откидывались (умирали на текущей позиции XY).
- Добавлено: раздел DEMOS теперь поддерживает вложенные каталоги.
- Добавлено: конс команда "randommodels". Всем игрокам ставит рандомные модели (из доступных). Полезно при просмотре демок, если все играют одинаковыми моделями.
- Исправлено: глюк тянувшийся с nfk035 - оружие криво отрисовывается, наконец-то исправлен.
- Добавлено: при включенном r_fx_quad. Чел (при наличии quad) из красной команды светится красным.
- Добавлено: скроллинг консоли скроллером (на мышке).
- Исправлено: чат сообщения ("say"), всегда отправлялись только в нижнем регистре. Теперь можно отправлять в любом.
- Добавлено: добавлена CTF карта ctf1.mapa
- Исправлено: Оружие теперь находится 100% ровно (и при центровке тоже).
- Добавлено: В редакторе карт можно экспортировать custom brick палитру.
- Исправлено: если в папке maps находился левый файл (например cfg) - вылетало в главное меню.
- Добавлено: Заходить в подкаталоги в списке карт, теперь можно кнопкой mbutton2, 3.
- Исправлено: раньше, если записать демку, а потом выйти в DEMOS, то записанная демка там не появлялась, теперь все ОК.
- Исправлено: командa autorecord: при записи дата и время не изменялись (в названии демки), тоесть запись происходила в один и тотже файл.
- Изменено: команда autorecord теперь записывает не internal map name, а map filename. +Дописывает какой был режим игры (dm,ctf..)
- Изменено: команда autorecord: если игроков слишком много то их имена обрезаются, (длина имен в названии = 30 - КолвоИгроков * 3).
- Добавлено: скроллинг скроллером (на мышке) демок в окне DEMOS, а также заход в папки кнопками mbutton2, 3.
- Исправлено: раньше у gauntlet'а, при повороте, иногда появлялся левый (ненужный) пиксель.
- Добавлено: редактирование значений domlimit, capturelimit теперь доступно в меню multiplayer\create server
- Изменено: теперь fraglimit не учитывается в режиме игры CAPTURE THE FLAG
- Изменено: теперь timelimit и fraglimit не учитываются в режиме игры DOMINATION
- Добавлено: новая конс команда "cl_avimode". [0] - cl_avidemo записывает в jpg. [1] - cl_avidemo записывает в bmp.
- Изменено: теперь, если написать "model sarge", то автоматически выберется модель sarge+default. (это распространяется на p2model, enemymodel, teammodel)
- Исправлено: Раньше, при использовании trixmasta, в имени демки не убирались тэги цвета от имени игрока
- изменено: дефалтные значения capturelimit=8 domlimit=400.
- Изменено: максимальное значение forcerespawn теперь равно 10ти.
- Изменено: улучшена навигация по окну DEMOS (запоминание последней директории, home\end кнопки, итд)

ver 0.37
- Добавлено: новый тип игры "teamplay". Доступен только по мультиплееру.
- Исправлено: Неправильно передавались данные по мультиплееру о откидывании игрока. Это иногда вызывало расхождение между реальной скоростью полета игрока и текущей скоростью.
- Исправлено: если запись демку на большой карте, то демка изза этого становилась глючной.
- Исправлено: если записывать демку и выстрелить из BFG, то демка изза этого становилась глючной.
- Исправлено: после игры в trixarena, в хотсите не было статусбара2.
- Добавлено: команда "zoomwindow" - растягивает окно нфк (в оконном режиме) до размеров десктопа. Тоесть появилась возможность играть при различных разрешениях, но это всеголишь растяжение, и дополнительного пространства для зрения вы не получите.
- Изменено: теперь нфк автоматически обнаруживает видеокарты не поддерживающие 32битный режим, в этом случае сама переключается в режим "lowbitdepth".
- Исправлено: иногда игрок смотрел в неправильную сторону при респавне на больших картах.
- Исправлено: в мультиплеере звук от machinegun на больших картах на клиенте иногда не проигрывался.
- Исправлено: команда "currenttime" глючила.
- Исправлено: на больших картах камера не "плотно" следила за игроком, иногда отклонялась.
- Исправлено: "cameratype 1" иногда включался на картах 30х20 (хотсит).
- Изменено: area_waterillusion не отрисовывается поверх water, чтобы избежать двойной отрисовки воды на один брик (это для тех кто area_waterillusion устанавливать не умеет :).
- Исправлено: полет трупа неправильно отображался на клиентах по мультиплееру.
- Добавлено: новые конфиги 1v1.cfg  team.cfg  ffa.cfg  default.cfg
Новая версия редактора карт NFKRadiant. v037:
- Добавлено: новые красивые иконки.
- Добавлено: операция "fill border". создает бордюр карты.
- Добавлено: возможность выбора (select) участка карты. (правая кнопка мыши). (tnx [LD]:Surgeon).
- Добавлено: Выбранный участок карты можно залить выбранным брашем.
- Добавлено: Выбранный участок карты можно очистить.
- Добавлено: Выбранный участок карты можно отразить по горизонтали.
- Добавлено: Выбранный участок карты можно отразить по вертикали.
- Добавлено: Выбранный участок карты можно скопировать в буфер обмена.
- Добавлено: Вставка участка карты из буфера обмена.
- Добавлено: Теперь нфк карты (*.mapa) можно ассоциировать с NFKRadiant.exe.
- Добавлено: если зажать 3тью кнопку мыши и двигать мышь, то будет двигаться поле.
- Добавлено: туториал по NFKRadiant от Rocky (http://n-f-k.narod.ru).

ver 0.35b
- Исправлено: нфк висло если в бордюр запихать респавн или empty brick.
- Исправлено: неправильно мигали статус бары при подбирании предметов в мультиплеере.
- Добавлено: панелька "fragbar", которая отображает ваше колво фрагов и фраги лучшего противника. (только по МП). Команды: "drawfragbar", "fragbarx", "fragbary"
- Исправлено: через nfkradiant можно было поставить несуществующий бэкграунд.
- Изменено: теперь поверапы не лежат с начала партии, они респавнятся через 30-60 сек после старта. В трик арене поверапы респавнятся сразу.
- Исправлено: звук респавна поверапа не был слышен на клиентах.
- Исправлено: если на клиенте в вармапе набрать поверапов +записывать демку. то в демке после начала партии поверапы у игроков оставались.
- Исправлено: двери которые изначально открыты, не работали на клиенте и в демках.
- Добавлено: команда "sv_lock". Она запрещает изменение команд "timelimit, fraglimit, forcerespawn, railarenainstagib, sync". Снять lock можно только если закрыть сервер.
- Добавлено: В окне DEMOS если скроллировать c зажатой кнопкой TAB, то увеличивается скорость скроллинга.
- Исправлено: приседание, и balloon (синяя фигня над головой изза консоли), иногда не правильно сохранялись в демку.
- Сделано: крутая оптимизация обработчика больших карт. теперь большие карты требуют намного меньше системных ресурсов.
- Исправлено: в мультиплеере работал god :0 (на сервере).

ver 0.35a
- Исправлено: нельзя было играть больше чем 2 чела по мультиплееру.
- Исправлено: не на всех картах работал объект area_waterillusion.
- Исправлено: на некоторых картах не правильно работал объект doortrigger.
- Исправлено: аптечки +5 отрисовывались слегка "криво".
- Добавлено: команда "m_accelerate" аксель мыши.
- Исправлено: глюки с проигрыванием звуков на не пропорциональных картах типа 250х30.
- Исправленные и дополненные хелп файлы.

ver 0.35
- По поводу мультиплеера: если тут все писать, то очень много получится. Так что просто скажу:
- Добавлено: мультиплеер.
- Изменено: увеличена скорость загрузки нфк.
- Добавлено: новые настройки мыши (инверт, замена оси Y на Х).
- Добавлено: возможность создания dedicated сервера. Сервер без серверных игроков.
- Добавлено: команда "sync" [1-3]. Частота синхронизации между клиентом и сервером. Для лана-1, для модема -3..
- Добавлено: Spectator. Возможность наблюдать за матчем без участия. (только по мультиплееру).
- Добавлено: поддержка цветных имен. Тэги как в Quake3. ^1my^2name^3now^4^bcolored.. Тэг "^b" делает текст мигающим.
- Добавлено: новый артефакт "invisibility" невидимость. Действует тока по multiplayer.
- Заменена графика броней, аптечек.
- Изменено: Демки теперь с внутренней bzip компрессией.
- Исправлено: Если дверь проходила через брики, то при ее открытии эти брики становились проходимыми.
- Убраны команды: "nfkitemsspawn", "paredrail", "fill_r","fill_g","fill_b".
- Добавлена команда "kickplayer <playersid>" - принудительное отключение клиентов. Где <playerid> это ID полученный командой getplayersid.
- Добавлены новые бинды: "movedown" "scoreboard"
- Исправлено: нфк висло если слишком много карт.
- Исправлено: нфк игнорировало модели если их больше чем 107.
- Добавлено: команда "shownickatsb" - подписывает статусбары.
- В окне HOTSEAT список карт можно скроллировать мышью.
- В окне DEMOS появился scrollbar.
- Консоль, шафт, shotgun\machinegun marks, взрывы, снаряд БФГ, теперь прозрачные.
- Добавлена вода. В ней можно тонуть\плавать\пускать пузырики :).
- Перестроен формат моделей\карт\демок.
- Добавлено приседание\ползание.
- Полностью переделан графический движок игры.

pre035betatesting:

ver 0.34d:
- Добавлено: команда "bar2assing". Назначает второй статус бар выбранному игроку (в демках которые записаны под мультиплеером).
- Исправлено: всегда показывалась надпись "following ..."
- Исправлено: не работал autorecord.
- Изменено: улучшена система сглаживания перемещения игроков по мультиплееру. Теперь значительно меньше "лагает".

ver 0.34c:
- Добавлено: запись демок под мульти плеером.
- Исправлено: теперь чат действительно отправляется по CTRL+ENTER
- Исправлено: игрок иногда вставал если сидел в 2хбриковом корридоре.
- Исправлено: можно было сесть на джамппад, тем самым заклинив его...
- Исправлено: не работал area_teleport.
- Изменено: терь при "smoke 0" дым от haste всерaвно отображается.
- Исправлено: в окне p2prop неправильно отображались цвета рэила и кроссхаира.
- Исправлено: глюки со статусбарами, они иногда некорректно отображали поверапы.
- Добавлено: теперь статистика в конце партии выводится на консоль.
- Исправлено: если ник заезжал за пределы экрана при "shownick 1", это вызывало ошибку.
- Возможно исправлено: нфк иногда при компрессии демки портил ее, изза чего она потом не декомпрессировалась.
- Исправлено: если сделать карту без потолка и залить ее водой, то если пузыри всплывут за верхнюю границу карты - это вызывало ошибку.
- Исправлено: физика трупа вводе несоответствовала физике игрока в воде.
- Исправлено: если включить gauntlet и тонуть вводе, то будет звук gauntl_a.wav (звук удара).
- Исправлено: в режиме игры practice, если на карте небыло рокета, то он всеравно включался у респавнутого чела.
- Добавлено: правильное воспроизведение звука на (очень) больших картах. с учётом cameratype.
- Исправлено: в демке, таймер вармапа продолжал идти после окончания демки.
- Исправлено: если играть на клиенте, то при собирании армора и хелсы, статус бар апдейтился не сразу.
- Исправлено: balloon не сохранялся в демку.
- Исправлено: можно было ставить паузу в мультиплеере. (тоесть сервак поставил паузу, а у клиентов игра идет. и наоборот).
- Исправлено: иногда дисконнект игроков вызывал access violation (ошибка).
- Исправлено: map_info (надпись "deathmatch in map_name") неправильно показывалась в демках.
- Исправлено: иногда в консоли исчезала history введенных команд.
- Добавлено: смена модели\имени игрока1 теперь записывается в демку.
- Возможно исправлено: Можно было убить друг друга ракетами (+1 фраг каждому), причем один из игроком блюхался (blewhimself -1frag). Тоесть, умерли оба, а фраг тока одному. Типа исправлено, хотя хз.
- Исправлено: нельзя было тонуть, если присесть в воде высотой 2 брика.
- Исправлено: не показывался индикатор воздуха, если присесть в воде высотой 2 брика.

ver 0.34b:
- Исправлено: нельзя было написать длинный нэйм в плеер пропертиз.
- Исправлено: При написании хостнейма, начиналась игра, если нажать F (Fight).
- Исправлено: не отрисовывались иконки наград в статистике.
- Исправлено: трупы двигались за их хозяином :).
- Исправлено: при коннекте к серваку через TCP\IP два раза запрашивался IP адрес (возможно и по другим соединениям).
- Изменено: в окне мультиплеер, если нфк свернулась в окно, то теперь она снова возвращается в фуллскрин.
- Исправлено: в хотсите, трупы неправильно сохранялись в демку.
- Исправлено: в демках записанных в хотсите, над игроками появлялся мультиплеерный значёк "нет сигнала".
- Исправлено: в окне Player_2_properties нельзя выбрать черный цвет raila и кроссхаира.
- Исправлено: Теперь тэг ^b останавливает тэг ^n.
- Исправлено: параметр командной строки "gowindow" не запускал нфк в оконном режиме.
- Изменено: Кровь, вид разрыва чувака на куски... Вроде лучше стало.
- Добавлено: новый спец объект area_waterillusion. Это заплатка ввиде воды, чисто визуальный эффект. Это нужно для того чтобы ложить предметы под водой. Как он действует я показал в приложенной мапе (test1.mapa).
- Исправлено: в мультиплеере, double respawn bug.
- Исправлено: невидимого чувака можно было обнаружить командой "shownick 1" :). Теперь награды и ники над невидимыми не показываются (в мп).
- Апгрежен режим спектаторства (смотреть за игрой, без участия), чтобы включить этот режим нужно написать "spectator 1" перед подсоединением, в игре действует команда "nextplayer" - смена игрока, за которым следить.
- Изменнено: теперь dedicated сервер автоматом переходит в режим спектатора.
- Исправлено: неправильно отображались виды соединений (в мп окне) на некоторых компах.
- Исправлено: В окне создания сервера нельзя было нажать FIGHT enter'ом.

ver 0.31
- Исправлено: Рэил иногда не защитывался при попадании в голову
- Добавлено: в моделях можно указывать скорость анимации смерти.
- Добавлено: новая модель sarge. Она теперь является дефалтной.
- Добавлено. в меню хотсит менять gametype можно нажав одновременно 2 кнопки мыши.
- Добавлено: кривые модели при загрузке теперь игнорируются.
- Исправлено: если какойнибудь файл положить в каталог models то это вызывало фатальный глюк.
- Исправлено: плазминки иногда пропадали (в демках).
- Изменено: хелп, теперь в нем есть скриншоты всех предметов и их описание.
- Добавлено: мясо отлетает от взрывов.
- Добавлено: instagib в railarena включается\отключается командой "railarenainstagib"
- Добавлено: окно "Customize controlz". Находится в prayer propertiez.
- Исправлено: в версии 030 была начисто убита анимация крови.
- Изменено: в оконнном режиме, в игре, при не выдвинутой консоли курсор не выскакивает за пределы окна.
- Изменено: тип игры "trix arena" отсутствует в списке типов игр. он включается и отключается автоматически.
- Добавлено: новый тип игры "practice" - партия со всеми оружиями и без предметов (как warmup).
- Добавлено: команды "fill_r", "fill_g", "fill_b" - закраска заднего фона RGB цветом при "drawbackground 0"
- Добавлено: ускорение\замедление демки доступно на клавишах num- num+
- Добавлено: новый тип игры rail arena.
- Добавлено: продвинутый режим игры в trix arena - trix masta. подробнее в хелпе.
- Добавлено: в начале партии выводится информация о текущей карте +показывает скока timelimit и fraglimit.
- Добавлено: скорость анимации хождения игрока увеличивается если есть haste.
- Добавлено: новые параметры командной строки, список - в хелпе.
- Добавлено: новый специальный объект "doortrigger" (only shootable). Ставится он параллельно дверям, и нужен для того чтобы двери от выстрела открывались.
- Добавлено, в эдиторе: подтверждение выхода из программы.
- Добавлено: команда prevweapon (bind {key} prevweapon).
- Исправлено: граната отскакивала иногда неправильно (угол расчитывался неверно).
- Добавлена прога "playlist generator for NFKAMP"
- Исправлено: луч railgun'а иногда слегка отклонялся от кроссхаира (за одно этот же глюк исправлен во всех оружиях).
- Добавлено: команда "gauntletnextweapon" (p2gauntletnextweapon). Исключает gauntlet из списка nextweapon.
- Добавлено: счетчик наград в статистике.
- Добавлено: не знаю как это называется, но в ку3 это называется Balloon. Такая синяя хрень над головой (когда игрок в консоли).
- Добавлено: Задний фон консоли теперь текстурированный.
- Добавлено: новая награда "humiliation", дается за убийство gauntlet ом. Добавлена статистика под gauntlet.
- Добавлено: новое оружие gauntlet.
- Исправлено: консольная команда "map" делала рестарт если карта не была найдена.
- Исправлено: глюки с сообщением "blasted by 's bfg".
- Добавлено: команда "mp3volume" - громкость музыки в nfk.
- Добавлено: команда "volume" - громкость звуков в nfk (глючит слегка :).
- Добавлен проигрыватель mp3 файлов (nfkamp). Команды: "mp3play", "mp3next", "mp3reset", "mp3stop".
- Исправлено: у первого игрока можно поставить crosstype 5, а у второго нельзя
- Добавлено: команда "menucolor" - меняет цвет меню которое по ESC в игре.
- Исправлено: в демке можно было сделать рестарт карты.
- Исправлено: p2model в меню с консоли можно было указать любой, а потом зайти в p2prop и все висит..
- Добавлено: "nfk.exe protected" - запуск нфк в "урезанном" режиме.
- Добавлена команда "cachelevel", которая регулирует степень динамического loading'a.
- Добавлено: динамический loading звуков моделей.
- Добавлено: динамический loading графики моделей.
- Добавлено: динамический loading бэкграундов.
- Исправлено: иногда спавнилось больше чем 2 игрока в хотсите :)).
- Исправлено: не грузился autoexec.cfg
- Исправлено: "nfk.exe nosound" сбрасывал конфиг на дефалт.
- Исправлено: в демках: если игрок стоит на самом краю брика, в демке он падает вниз, долетает до земли и снова оказывается на брике (а на самом деле игрок стоял и не двигался).
- Исправлено: в демках, если убивают с гренады, пишут что убили с рокета
- Добавлено:  в демках, движение игрока теперь более плавное.
- Исправлено: в демках, граната отклонялась от ее "реальной" траектории.
- Добавлено:  в демках, запись в демку звука noammo.wav
- Исправлено: триггер реагировал на труп
- Изменено: чуть-чуть уменьшена отталкиваемость шафтом и плазмой. дмг плазмы теперь 14 (был 15).
- Исправлено: в player properties зажать ESC и сразу выкидывало в главное меню.
- Добавлен скролл хистори комманд по кнопке вниз (в консоли).
- Исправлено: в хотсит окне при выдвинутой консоли можно было нажать FIGHT.
- Исправлены глюки "range check error", которые незаметно глючили бэкграунде (отловил дебаггом, хехе).

ver 0.30
- Введен новый формат карт. Старые конвертируются через editor.
- Добавлены порталы, кнопки, двери, триггеры.
- Исправлен глюк со статистикой
- Исправлен глюк: иногда конфиг слетал на "дефалт".
- Исправлено: Теперь при выборе карты ее не загружают миллион раз, только тогда когда надо.
- Исправлено: система наведения кроссхаиром. Раньше при большой скорости движения игрока выстрелы немного "отклонялись", тем самым вызывали неточность попаданий.
- Сделан крутой мап эдитор.
- Cменились шрифты. Теперь они 14,12,10,8х размеров. Использован шрифт "VAG Rounded Thin"
- Добавлена команда "mousesmooth" - это ограничитель скорости мыши.
- В эдитор встроен конвентер карт из nfkbeta025 в формат карт nfkbeta030.
- Исправлен порядок отрисовки спрайтов (раньше, если шавтить под ноги, то шафт отрисовывался за игроком).
- Команда командной строки "windowed" сменилась на "gowindow";
- Рэилган теперь наносит повреждение 75 (вместо 85).
- Сделан нормальный warmup (разыгровка до партии). Теперь в вармапе дают оружия которые есть на карте (и патроны). Игроки спавнятся с 100 армора.
- Исправлено: Статистика в конце партии не выводит инфу о оружиях которых на карте нет.
- Исправлено: Статистика теперь правильно подсчитывает количество попаданий.
- Добавлено: 2 бонуса: "impressive", "excellent". 1ый - за 3 подряд попадания рэила. 2ой-Если в 2.5 секунды сделали 2 фрага.
- Добавлена автосмена оружия (если предыдущее закончилось), команда "weaponswitch_on_end".
- Был введен специальный алгоритм, заменяющий операции с cosinus и sinus. Теперь процессор напрягается меньше, следовательно небольшой прирост производительности.
- Граната теперь наносит повреждение не больше 50.
- Луч рэилгана теперь отрисовывается из конца реилгана, а не из центра модели.
- Добавлена возможность смены моделей игрока. Возможность создания для NFK дополнительных моделей.
- Созданы объекты "area_push", "area_pain" - триггера с соответствующим действием.
- Advanced физика убрана. Теперь только simple.
- Перестроен "движок" меню.
- Сделано окно "Credits".
- Новый алгоритм записи демок. Без архивации они теперь весят на 25% меньше.
- Исправлены глюки с frag\time limit, suddendeath
- Некоторые кнопки могут быть shootable.
- Создан объект "area_trixarena_end" - конец уровня для trix arena.
- Теперь можно записывать демки!
- Задние фоны теперь вынесены в отдельный background.jpg. Это убавило вес игры на ~1мб.
- Имена игроков теперь пишутся над игроками.
- Окно DEMOS, там можно выбрать демку для проигрывания.
- Добавлена команда "autorecord", которая за вас придумывает имя демки.
- Добавлено 4 новых задних фона.
- Добавлены предметы trix rocket и trix grenade. Оружия с одним патроном и они не респавнятся.
- Сделаны хоткеи на все пункты главного меню. H=Hotseat итд.
- В nfk появился тип игры TRIX ARENA.
- Изменен внешний вид взрыва.
- Ники теперь держат регистр.
- Теперь можно биндить все 3 кнопки мыши.
- Теперь можно перевесить управление с мыши полностью на клаву.

pre030betatesting:

ver 0.29h
- Исправлено: нфк вис если 1 респавн. еще теперь если 0 респавнов то игроки не появляются.
- Вродебы исправлен глюк с тем что один фрейм анимации смерти исчезал...
- Команды опасные для демки (типа READY итп) в демке отключаются.
- Доконца исправлены глюки с трупами.
- Добавлена конс команда "log" [0|1]. отключает\включает запись лог файла.
- Добавлено: теперь сообщения на консоли теперь выводятся некоторое время в игре. Добавлена конс команда "messagetime".
- Добавлено: Новый спец объект. area_teleport. Поддерживается radiant'oм v029 или выше.
- Добавлена команда "noplayer" [0,1,2] - 0=2 игрока;1=нет игрока 1;2=нет игрока 2.
- Исправлено: телепорт иногда телепортировал трупы.
- Обновлены: хелп, хелп к радианту.
- Изменено: теперь при nfkitemspawn 1, арморы респавнятся через 30 сек (красный и желтый).
- Исправлено: анимация смерти у трупов иногда не доконца проигрывалась. (в демке).
Новый NFKRadiant v029:
- Добавлена функция "Brush Replace", возможность массово заменять одни брики на другие.
- Исправлен глюк в Select Object. положение по Y, писалось как по X.
- Теперь radiant по возможности открывает сам предыдущюю директорию (откуда мапу загружали, итп).
- Добавлено Map Demo Extractor. Вытаскивает мапы из демок.
- Исправлено: у двери можно было поставить wait 0.
- Исправлено: при создании\открытии мапы, в списке оставались свойства от предыдущей.

ver 0.29g
- Иногда начинают пропадать звуки. Добавлена команда "sndrestart", которая это лечит. Эта команда вызывается автоматически при загрузке карты из меню.
- Исправлен глюк с выбором несуществующей модели.
- Действительно исправлено: иногда кровь и дым зависали в воздухе (в невидимом состоянии) и висели там до конца партии.
- Исправлено: двери и кнопки не возвращались в исходное состояние после начала матча. (в демке).
- Исправлено: в демку неккоректно записывались предметы которые лежат на карте.
- Исправлено: мап_рестарт убивал статистику в демке при записи.
- Исправлено: когда двери давили трупов, то они проваливались. Теперь они исчезают.
- Изменено: теперь синхронизация гранаты 8ми тактовая. т.е. еще меньше шанс отклонения гранаты в демке.
- Исправлено: иногда статистика в демке была неправильна.
- Изменено: теперь следущие оружие не стрелят так быстро после переключения.
- Теперь нормально работают команды: "midiplay, midinext, midistop";

ver 0.29f
- Исправлено: Если перед концом записи демки напускать ракет и остановить демку, то потом при проигрывании ракеты улетали в никуда.
- Исправлено: в демке награда иногда висела над респавнутым чуваком (если была до смерти).
- Добавлено: что то вроде скроллбара на списке карт. (Который мышью таскать нельзя)
- Исправлено: если в списке карт нажать PGUP то нфк выдавал "Программа выполнила...".
- Добавлено: В списке карт работают кнопки "home", "end".
- Добавлено: Если есть файл "autoexec.cfg", то при загрузке NFK его exec'ает.
- Дефалтная модель игрока 2 теперь "enforcer+blue".
- Изменено: Теперь респавнится можно по кнопке fire. Можно лежать в мертвом состоянии. Трупы лежат на карте.
- Добавлена четырех-тактовая синхронизация полета гранаты в демке, что исключает любое отклонение полёта от "реального" (как было в реале а не в деме).
- Исправлено: серьезные глюки с дверьми\кнопками в демах (было: если открыть дверь и начать запись то в деме дверь не будет открыта).
- Изменено: Максимальное повреждение шотгана теперь 75.
- Изменено: звуки (*.wav) теперь ужаты с помощью проги SoundForge. Ужаты некоторые спрайты. НФК теперь будет весить не 5.5 мб, а около 3-4 мб.
- Исправлены окончательно глюки с PGUP\PGDN в списке мап.
- Изменен алгоритм смены оружия, теперь когда вы жмете nextweapon или набинденный weapon, то вас не переключают на то оружие, а ставят вам желаемое оружие, то которое выбрали. И если потом вы не стреляете и не меняете оружие, то вас переключают на желаемое оружие. Такой алгорим значительно уменьшает зажимаемость кнопок на переключении оружия.
- Добавлена специальная панель, которая показывает какие у вас есть оружия, и в каких есть патроны.
- Исправлено: hitsound срабатывал когда себя ранишь ракетой.
- Исправлено: иногда кровь и дым зависали в воздухе (в невидимом состоянии) и висели там до конца партии.
- Добавлены команды: "forcerespawn, weapbartime, p2weapbartime";
- Обновлен хэлп
- Добавлено ускорение скроллинга по кнопке Пробел, в окне CREDITS.
- В этой версии глючат трупы, так что не надо...

ver 0.29e
- Пофиксены мелкие клюки с демами.
- Добавлена карта TRICK3.
- Добавлена команда "paredrail 1". (Уменьшенный регион попадания рэила).
- Граната теперь наносит повреждение 65.
- Добавлена команда "nfkitemspawn 0". 0-время спавнов как в ку3. 1-спавны как в NFK.
- Исправлено: в окне "DEMOS", если в консоли нажать ENTER то начинала играться дема.
- В списке карт теперь работают кнопки "pageup", "pagedown".

ver 0.29d
- команда unbindkeys не отбиндивала fire,lookup,lookdown.
- теперь при бинде одного и того же значения на 2 кнопки, предыдущая автоматом отбиндивается.
- Время поверапов "просвечивало" через окно статистики
- Добавлено меню в игре по кнопке ESC.
- Исправлено: иногда нахаляву давали "impressive"
- Исправлено: Можно было после просмотра демки играть на карте из демки.

ver 0.29c
- исправлено: нфк неправильно определял регионы где игрок находится. Изза этого неправильно закрывались горизонтальные двери, глючили триггеры, area.
- исправлено: area_ta_end не срабатывал, если снизу дотронулись головой.
- теперь в вармапе, area_ta_end наносит дмг и говорит "вали отсюда".
- исправлено: если летать с поверапом flight и записать в демку, то потом в демке звук полета был неправильный.
- изменено: новая подложка под статистику (stats.jpg)
- Добавлена новая триковая карта trick2. и демка прохождения на ней.
- исправлено: "DEATH" не убивал в голову.
- Добавлен чит: "give battle" (battle,regen,haste,quad,fly).
- предметы trix rl,gl не респавнятся после взятия. Оказывается они нереспавнятся после мапрестарта! исправлено.
- исправлено: Иногда в вармапе не давали броню, оружие.

ver 0.29b
- исправлено: Если на карте есть только bfg ,то в warmup'е вместо него у тебя плазмаган которого нету на карте.
- исправлено: двери некорректно записывали в дему свое положение. Гранаты через двери пролетали.

ver 0.25:
- Добавлены команды "unbindkeys", "p2unbindkeys".
- Порядок отрисовки игроков был от первого до последнего. Теперь порядок выбирается по рандому.
- Если вдвоем встать на предмет, то после его появления он всегда доставался 1му игроку. Сейчас по рандому.
- Добавлено несколько пунктов в главное меню.
- Добавлено окно "SETUP".
- Коробка рэила добавляла 10 слагов, теперь 5.
- Рэилган теперь пробивает через игроков насквозь.
- При попадании machinegun'ом кровь теперь отрисовывается только в том месте куда попали.
- Изменились цвета рэилгана. Они с 1 по 7. Теперь после выстрела луч постепенно "остывает".
- Добавлена команда "railtrailtime". Колво времени на "остывание" рэилгана.
- Добавлена команда "hitsound", которая включает проигрывание звука при попадании в противника.
- Теперь аптечки анимированные. Они мигают.
- Превью карт в меню!
- Добавлены команды "gibblood","gibvelocity". Включают кровь у мяса, и мясо летит в сторону относительно точки попадания.
- Надписи в меню теперь плавно меняют цвет.
- Армор теперь "парит" на месте.
- Консоль теперь доступна и в меню.
- Появилась команда "Disconnect" - Выгружает карту и возвращает в меню.
- Добавлены параметры командной строки: "windowed"=запускаться в оконном режиме. "bit8"=3апускаться в режиме 640x480x8 (ужасно выглядит). "nosound"=отключает загрузку wav файлов в память и отключает звук. Эти параметры вводятся так "nfk.exe windowed" итд. ps: команды "bit16,bit24" есть еще.
- Сделан quad, regeneration, flight, battlesuit, haste. С новыми звуками и графикой.
- Добавлены звуки при выборе пунктов в меню
- Добавлены 2 окна в меню. "Player 1 properties" & "Player 2 properties".
- Переделаны некоторые дефалтные мапы.
- Добавлена пауза в игре на PAUSE. Только если аль+табите то не забывайте послеэтого PAUSE снова нажать.
- Добавлена команда "currenttime".
- Перестроена структура exe файла. Теперь вся графика загружается отдельно. Быстрей работает.
- Добавлена статистика, которая вываливается в конце игры.
- Добавлена новая анимация меню. Теперь при смене окна меню экран плавно гаснет и зажигается.
- Добавлено loading окно, в котором при загрузке нфк пишет что он загружает.
- Консольная команда "ready" теперь на F10.